<!doctype html>
<html data-n-head-ssr lang="en" data-n-head="lang">
  <head>
    <title data-n-head="true">Low pressure lingering off East Coast brings gusty winds, high surf, rip currents and coastal flooding</title><meta data-n-head="true" http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"><meta data-n-head="true" name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no"><meta data-n-head="true" charset="UTF-8"><meta data-n-head="true" name="format-detection" content="telephone=no"><meta data-n-head="true" name="msapplication-square70x70logo" content="//static.foxtv.com/static/orion/img/wogx/favicons/mstile-70x70.png"><meta data-n-head="true" name="msapplication-square150x150logo" content="//static.foxtv.com/static/orion/img/wogx/favicons/mstile-150x150.png"><meta data-n-head="true" name="msapplication-wide310x150logo" content="//static.foxtv.com/static/orion/img/wogx/favicons/mstile-310x150.png"><meta data-n-head="true" name="msapplication-square310x310logo" content="//static.foxtv.com/static/orion/img/wogx/favicons/mstile-310x310.png"><meta data-n-head="true" data-hid="description" name="description" content="A pesky low-pressure system that developed off the East Coast over Mother&#x27;s Day weekend continues to meander in the western Atlantic Ocean, creating gusty winds, high surf, rip currents and coastal flooding from the mid-Atlantic southward to Florida."><meta data-n-head="true" data-hid="fb:app_id" property="fb:app_id" content="115512618480878"><meta data-n-head="true" data-hid="prism.stationId" name="prism.stationId" content="WOGX_FOX51"><meta data-n-head="true" data-hid="prism.stationCallSign" name="prism.stationCallSign" content="wogx"><meta data-n-head="true" data-hid="prism.channel" name="prism.channel" content="fts"><meta data-n-head="true" data-hid="prism.section" name="prism.section" content="news"><meta data-n-head="true" data-hid="prism.subsection1" name="prism.subsection1" content=""><meta data-n-head="true" data-hid="prism.subsection2" name="prism.subsection2" content=""><meta data-n-head="true" data-hid="prism.subsection3" name="prism.subsection3" content=""><meta data-n-head="true" data-hid="prism.subsection4" name="prism.subsection4" content=""><meta data-n-head="true" data-hid="prism.aggregationType" name="prism.aggregationType" content="subsection"><meta data-n-head="true" data-hid="prism.genre" name="prism.genre" content=""><meta data-n-head="true" data-hid="pagetype" name="pagetype" content="article" scheme="dcterms.DCMIType"><meta data-n-head="true" data-hid="strikepagetype" name="strikepagetype" content="article" scheme="dcterms.DCMIType"><meta data-n-head="true" data-hid="content-creator" name="content-creator" content="tiger"><meta data-n-head="true" data-hid="dc.creator" name="dc.creator" scheme="dcterms.creator" content=""><meta data-n-head="true" data-hid="dc.title" name="dc.title" content="Low pressure lingering off East Coast brings gusty winds, high surf, rip currents and coastal flooding" lang="en"><meta data-n-head="true" data-hid="dc.subject" name="dc.subject" content=""><meta data-n-head="true" data-hid="dcterms.abstract" name="dcterms.abstract" content="A pesky low-pressure system that developed off the East Coast over Mother&#x27;s Day weekend continues to meander in the western Atlantic Ocean, creating gusty winds, high surf, rip currents and coastal flooding from the mid-Atlantic southward to Florida."><meta data-n-head="true" data-hid="dc.type" name="dc.type" scheme="dcterms.DCMIType" content="Text.Article"><meta data-n-head="true" data-hid="dc.description" name="dc.description" content="A pesky low-pressure system that developed off the East Coast over Mother&#x27;s Day weekend continues to meander in the western Atlantic Ocean, creating gusty winds, high surf, rip currents and coastal flooding from the mid-Atlantic southward to Florida."><meta data-n-head="true" data-hid="dc.language" name="dc.language" scheme="dcterms.RFC4646" content="en-US"><meta data-n-head="true" data-hid="dc.publisher" name="dc.publisher" content="FOX 51 Gainesville"><meta data-n-head="true" data-hid="dc.format" name="dc.format" scheme="dcterms.URI" content="text/html"><meta data-n-head="true" data-hid="dc.identifier" name="dc.identifier" scheme="dcterms.URI" content="urn:uri:base64:02d9edd9-112e-5309-af50-2cc0666055be"><meta data-n-head="true" data-hid="dc.source" name="dc.source" content="FOX Weather"><meta data-n-head="true" data-hid="dc.date" name="dc.date" content="2022-05-11"><meta data-n-head="true" data-hid="dcterms.created" name="dcterms.created" scheme="dcterms.ISO8601" content="2022-05-11T21:41:49-04:00"><meta data-n-head="true" data-hid="dcterms.modified" name="dcterms.modified" scheme="dcterms.ISO8601" content="2022-05-11T23:18:06-04:00"><meta data-n-head="true" data-hid="og:title" property="og:title" content="Low pressure lingering off East Coast brings gusty winds, high surf, rip currents and coastal flooding"><meta data-n-head="true" data-hid="og:description" property="og:description" content="A pesky low-pressure system that developed off the East Coast over Mother&#x27;s Day weekend continues to meander in the western Atlantic Ocean, creating gusty winds, high surf, rip currents and coastal flooding from the mid-Atlantic southward to Florida."><meta data-n-head="true" data-hid="og:type" property="og:type" content="article"><meta data-n-head="true" data-hid="og:image" property="og:image" content="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/1280/720/79d1f2f7-ocean-storm.jpg?ve=1&amp;tl=1"><meta data-n-head="true" data-hid="og:image:width" property="og:image:width" content="1280"><meta data-n-head="true" data-hid="og:image:height" property="og:image:height" content="720"><meta data-n-head="true" data-hid="og:url" property="og:url" content="https://www.wogx.com/news/low-pressure-lingering-off-east-coast-brings-gusty-winds-high-surf-rip-currents-and-coastal-flooding"><meta data-n-head="true" data-hid="og:site_name" property="og:site_name" content="FOX 51 Gainesville"><meta data-n-head="true" data-hid="og:locale" property="og:locale" content="en_US"><meta data-n-head="true" data-hid="robots" name="robots" content="noarchive, noodp, max-image-preview:standard"><meta data-n-head="true" data-hid="fox.app_version" name="fox.app_version" content="v77"><meta data-n-head="true" data-hid="fox.app_build" name="fox.app_build" content="no build version"><meta data-n-head="true" name="apple-itunes-app" content="app-id=undefined, app-argument=https://www.wogx.com/news/low-pressure-lingering-off-east-coast-brings-gusty-winds-high-surf-rip-currents-and-coastal-flooding"><meta data-n-head="true" name="twitter:card" content="summary_large_image"><meta data-n-head="true" name="twitter:site" content="@wogxfox51"><meta data-n-head="true" name="twitter:site:id" content="@wogxfox51"><meta data-n-head="true" name="twitter:title" content="Low pressure lingering off East Coast brings gusty winds, high surf, rip currents and coastal flooding"><meta data-n-head="true" name="twitter:description" content="A pesky low-pressure system that developed off the East Coast over Mother&#x27;s Day weekend continues to meander in the western Atlantic Ocean, creating gusty winds, high surf, rip currents and coastal flooding from the mid-Atlantic southward to Florida."><meta data-n-head="true" name="twitter:image" content="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/1280/720/79d1f2f7-ocean-storm.jpg?ve=1&amp;tl=1"><meta data-n-head="true" name="twitter:url" content="https://www.wogx.com/news/low-pressure-lingering-off-east-coast-brings-gusty-winds-high-surf-rip-currents-and-coastal-flooding"><meta data-n-head="true" name="twitter:creator" content="@wogxfox51"><meta data-n-head="true" name="twitter:creator:id" content="@wogxfox51"><meta data-n-head="true" name="fox.name" content="Post Landing"><meta data-n-head="true" name="fox.category" content="news"><meta data-n-head="true" name="fox.page_content_category" content="news"><meta data-n-head="true" name="fox.page_name" content="wogx:web:post:article:Low pressure lingering off East Coast brings gusty winds, high surf, rip currents and coastal flooding"><meta data-n-head="true" name="fox.page_content_level_1" content="wogx:web:post"><meta data-n-head="true" name="fox.page_content_level_2" content="wogx:web:post:article"><meta data-n-head="true" name="fox.page_content_level_3" content="wogx:web:post:article:Low pressure lingering off East Coast brings gusty winds, high surf, rip currents and coastal flooding"><meta data-n-head="true" name="fox.page_content_level_4" content="wogx:web:post:article:Low pressure lingering off East Coast brings gusty winds, high surf, rip currents and coastal flooding"><meta data-n-head="true" name="fox.page_type" content="post-article"><meta data-n-head="true" name="fox.page_content_distributor" content="owned"><meta data-n-head="true" name="fox.page_content_type_of_story" content="Partner"><meta data-n-head="true" name="fox.author" content=""><meta data-n-head="true" name="fox.page_content_author" content=""><meta data-n-head="true" name="fox.page_content_author_secondary" content="Brian Donegan"><meta data-n-head="true" name="fox.page_content_version" content="2.0.0"><meta data-n-head="true" name="fox.publisher" content="FOX Weather"><meta data-n-head="true" name="fox.page_content_id" content="02d9edd9-112e-5309-af50-2cc0666055be"><meta data-n-head="true" name="fox.page_content_station_originator" content="wofl"><meta data-n-head="true" name="fox.url" content="https://www.wogx.com/news/low-pressure-lingering-off-east-coast-brings-gusty-winds-high-surf-rip-currents-and-coastal-flooding"><meta data-n-head="true" name="fox.page_canonical_url" content="https://www.foxweather.com/weather-news/east-coast-storm-wind-high-surf-rip-currents-coastal-flooding-may"><meta data-n-head="true" property="fb:app_id" content="115512618480878"><meta data-n-head="true" property="article:opinion" content="false"><meta data-n-head="true" name="keywords" content="Us,Fl,Marion County,Ocala,News"><meta data-n-head="true" name="classification" content="/FTS/Us/Fl/Marion County/Ocala,/FTS/News"><meta data-n-head="true" name="classification-isa" content="ocala,news"><meta data-n-head="true" name="fox.page_content_tags" content="/FTS/Us/Fl/Marion County/Ocala,/FTS/News"><link data-n-head="true" rel="icon" type="image/x-icon" href="/favicons/wogx/favicon.ico"><link data-n-head="true" rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open+Sans:300,400,400i,600,600i,700,700i,800,800i&amp;display=swap"><link data-n-head="true" rel="schema.dcterms" href="//purl.org/dc/terms/"><link data-n-head="true" rel="schema.prism" href="//prismstandard.org/namespaces/basic/2.1/"><link data-n-head="true" rel="schema.iptc" href="//iptc.org/std/nar/2006-10-01/"><link data-n-head="true" rel="shortcut icon" href="//static.foxtv.com/static/orion/img/wogx/favicons/favicon.ico" type="image/x-icon"><link data-n-head="true" rel="apple-touch-icon" sizes="57x57" href="//static.foxtv.com/static/orion/img/wogx/favicons/apple-touch-icon-57x57.png"><link data-n-head="true" rel="apple-touch-icon" sizes="60x60" href="//static.foxtv.com/static/orion/img/wogx/favicons/apple-touch-icon-60x60.png"><link data-n-head="true" rel="apple-touch-icon" sizes="72x72" href="//static.foxtv.com/static/orion/img/wogx/favicons/apple-touch-icon-72x72.png"><link data-n-head="true" rel="apple-touch-icon" sizes="76x76" href="//static.foxtv.com/static/orion/img/wogx/favicons/apple-touch-icon-76x76.png"><link data-n-head="true" rel="apple-touch-icon" sizes="114x114" href="//static.foxtv.com/static/orion/img/wogx/favicons/apple-touch-icon-114x114.png"><link data-n-head="true" rel="apple-touch-icon" sizes="120x120" href="//static.foxtv.com/static/orion/img/wogx/favicons/apple-touch-icon-120x120.png"><link data-n-head="true" rel="apple-touch-icon" sizes="144x144" href="//static.foxtv.com/static/orion/img/wogx/favicons/apple-touch-icon-144x144.png"><link data-n-head="true" rel="apple-touch-icon" sizes="152x152" href="//static.foxtv.com/static/orion/img/wogx/favicons/apple-touch-icon-152x152.png"><link data-n-head="true" rel="apple-touch-icon" sizes="180x180" href="//static.foxtv.com/static/orion/img/wogx/favicons/apple-touch-icon-180x180.png"><link data-n-head="true" rel="icon" type="image/png" href="//static.foxtv.com/static/orion/img/wogx/favicons/favicon-16x16.png" sizes="16x16"><link data-n-head="true" rel="icon" type="image/png" href="//static.foxtv.com/static/orion/img/wogx/favicons/favicon-32x32.png" sizes="32x32"><link data-n-head="true" rel="icon" type="image/png" href="//static.foxtv.com/static/orion/img/wogx/favicons/favicon-96x96.png" sizes="96x96"><link data-n-head="true" rel="icon" type="image/png" href="//static.foxtv.com/static/orion/img/wogx/favicons/android-chrome-192x192.png" sizes="192x192"><link data-n-head="true" rel="preconnect" href="https://cdn.segment.com/"><link data-n-head="true" rel="preconnect" href="https://w3.mp.lura.live/"><link data-n-head="true" rel="preconnect" href="https://widgets.media.weather.com/"><link data-n-head="true" rel="preconnect" href="https://elections.ap.org/"><link data-n-head="true" rel="preconnect" href="https://www.google-analytics.com/"><link data-n-head="true" rel="preconnect" href="http://static.chartbeat.com/"><link data-n-head="true" rel="preconnect" href="https://sb.scorecardresearch.com/"><link data-n-head="true" rel="preconnect" href="http://www.googletagmanager.com/"><link data-n-head="true" rel="preconnect" href="https://snippet.minute.ly/"><link data-n-head="true" rel="preconnect" href="https://cdn.optimizely.com/"><link data-n-head="true" rel="preconnect" href="https://js-agent.newrelic.com/"><link data-n-head="true" rel="preconnect" href="https://cdn.segment.com/"><link data-n-head="true" rel="preconnect" href="https://apv-launcher.minute.ly/"><link data-n-head="true" rel="preconnect" href="https://connect.facebook.net/"><link data-n-head="true" rel="canonical" href="https://www.foxweather.com/weather-news/east-coast-storm-wind-high-surf-rip-currents-coastal-flooding-may"><link data-n-head="true" rel="shorturl" href=""><link data-n-head="true" rel="image_src" href="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/1280/720/79d1f2f7-ocean-storm.jpg?ve=1&amp;tl=1"><link data-n-head="true" rel="amphtml" href="https://www.wogx.com/news/low-pressure-lingering-off-east-coast-brings-gusty-winds-high-surf-rip-currents-and-coastal-flooding.amp"><link data-n-head="true" rel="stylesheet" href="//static.foxtv.com/static/orion/css/default/article.rs.css"><link data-n-head="true" rel="stylesheet" href="/css/print.css" media="print"><script data-n-head="true" data-hid="nr-ssr" type="text/javascript" charset="utf-8">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</script><script data-n-head="true" src="https://scripts.webcontentassessor.com/scripts/ef4afbe31ab62a8ae0dd877d983ba92b5fdecfbcaf962df5cd9cbb96afceeca5"></script><script data-n-head="true" src="//static.foxtv.com/static/orion/scripts/core/ag.core.js"></script><script data-n-head="true" src="//static.foxtv.com/static/isa/core.js"></script><script data-n-head="true" src="//static.foxtv.com/static/orion/scripts/station/default/loader.js"></script><script data-n-head="true" src="https://widgets.media.weather.com/wxwidget.loader.js?cid=996314550" defer=""></script><script data-n-head="true" src="https://w3.mp.lura.live/player/prod/v3/scripts/anvload.js" defer=""></script><script data-n-head="true" src="//static.foxtv.com/static/leap/loader.js"></script><script data-n-head="true" >(function () {
        var _sf_async_config = window._sf_async_config = (window._sf_async_config || {})
        _sf_async_config.uid = 65824
        _sf_async_config.domain = 'wogx.com'
        _sf_async_config.flickerControl = false
        _sf_async_config.useCanonical = true
        _sf_async_config.useCanonicalDomain = true
        })()</script><script data-n-head="true" src="//static.chartbeat.com/js/chartbeat_mab.js"></script><script data-n-head="true" src="https://interactives.ap.org/election-results/assets/microsite/resizeClient.js" defer=""></script><script data-n-head="true" src="/js/cookies.js"></script><script data-n-head="true" type="application/ld+json">{"@context":"http://schema.org","@type":"NewsArticle","mainEntityOfPage":"https://www.foxweather.com/weather-news/east-coast-storm-wind-high-surf-rip-currents-coastal-flooding-may","headline":"Low pressure lingering off East Coast brings gusty winds, high surf, rip currents and coastal flooding","datePublished":"2022-05-11T21:41:49-04:00","dateModified":"2022-05-11T23:18:06-04:00","description":"A pesky low-pressure system that developed off the East Coast over Mother's Day weekend continues to meander in the western Atlantic Ocean, creating gusty winds, high surf, rip currents and coastal flooding from the mid-Atlantic southward to Florida.","author":{"@type":"Person","name":"FOX Weather"},"publisher":{"@type":"Organization","name":"FOX 51 Gainesville","logo":{"@type":"ImageObject","url":"https://static.foxtv.com/static/orion/img/wogx/favicons/favicon-96x96.png","width":"96","height":"96"}},"image":{"@type":"ImageObject","url":"https://static.wogx.com/www.wogx.com/content/uploads/2022/05/79d1f2f7-ocean-storm.jpg"},"tags":"ocala","keywords":"ocala"}</script><link rel="preload" href="/_wzln/c05903c53ff394793e81.js" as="script"><link rel="preload" href="/_wzln/f6c9ecd1fd0c1c60a56a.js" as="script"><link rel="preload" href="/_wzln/dd780842d04db44d39b9.js" as="script"><link rel="preload" href="/_wzln/6d0abfe0b75722f245e2.js" as="script"><link rel="preload" href="/_wzln/d0c01cd7fe6130c168aa.js" as="script"><link rel="preload" href="/_wzln/7dd24738d8a50f86501d.js" as="script"><link rel="preload" href="/_wzln/4781d29d1da383767fba.js" as="script"><style data-vue-ssr-id="4007f7ae:0 12f49b28:0 2263b607:0 91380424:0 1a21896c:0 78d3cac4:0 55f32066:0 f683bfbc:0 602ddfaa:0 f8d2b2a6:0 fb9cb2c0:0">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</style>
   
<script>(window.BOOMR_mq=window.BOOMR_mq||[]).push(["addVar",{"rua.upush":"false","rua.cpush":"true","rua.upre":"false","rua.cpre":"true","rua.uprl":"false","rua.cprl":"false","rua.cprf":"false","rua.trans":"SJ-403a3680-d8fd-426e-aa01-15779e9b9082","rua.cook":"false","rua.ims":"false","rua.ufprl":"false","rua.cfprl":"false","rua.isuxp":"false","rua.texp":"norulematch"}]);</script>
                              <script>!function(a){var e="https://s.go-mpulse.net/boomerang/",t="addEventListener";if("False"=="True")a.BOOMR_config=a.BOOMR_config||{},a.BOOMR_config.PageParams=a.BOOMR_config.PageParams||{},a.BOOMR_config.PageParams.pci=!0,e="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="HP9WN-429QT-AGR8G-FBNE8-3RFTX",function(){function n(e){a.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!a.BOOMR||!a.BOOMR.version&&!a.BOOMR.snippetExecuted){a.BOOMR=a.BOOMR||{},a.BOOMR.snippetExecuted=!0;var i,_,o,r=document.createElement("iframe");if(a[t])a[t]("load",n,!1);else if(a.attachEvent)a.attachEvent("onload",n);r.src="javascript:void(0)",r.title="",r.role="presentation",(r.frameElement||r).style.cssText="width:0;height:0;border:0;display:none;",o=document.getElementsByTagName("script")[0],o.parentNode.insertBefore(r,o);try{_=r.contentWindow.document}catch(O){i=document.domain,r.src="javascript:var d=document.open();d.domain='"+i+"';void(0);",_=r.contentWindow.document}_.open()._l=function(){var a=this.createElement("script");if(i)this.domain=i;a.id="boomr-if-as",a.src=e+"HP9WN-429QT-AGR8G-FBNE8-3RFTX",BOOMR_lstart=(new Date).getTime(),this.body.appendChild(a)},_.write("<bo"+'dy onload="document._l();">'),_.close()}}(),"".length>0)if(a&&"performance"in a&&a.performance&&"function"==typeof a.performance.setResourceTimingBufferSize)a.performance.setResourceTimingBufferSize();!function(){if(BOOMR=a.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var e="true"=="true"?1:0,t="",n="eow65cqx3lnesyt4voxa-f-90229b80f-clientnsv4-s.akamaihd.net",i="false"=="true"?2:1,_={"ak.v":"32","ak.cp":"879161","ak.ai":parseInt("561272",10),"ak.ol":"0","ak.cr":1,"ak.ipv":4,"ak.proto":"http/1.1","ak.rid":"ceb5784","ak.r":41188,"ak.a2":e,"ak.m":"dscr","ak.n":"ff","ak.bpcip":"35.173.238.0","ak.cport":33818,"ak.gh":"23.222.2.73","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"reno","ak.t":"1652337582","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==v4wJvgJki9ZT3xnaflcccWWRRx05tQFw70WQqXm3fJTFTMAfpNydd2CTxnheG5GhQQ+giGf0xfvdLh3DLAG+7l7imTB3D5UCxnHBO3nrBtFyq77wjCK/bBaQyduqNorUfaBLlT/GyS4UPL0L3DGoqV07xtimWEW2y2vK+d3BbcGCbV7LB4HpNmw1jF+k+w1wSfetKsAjHR1uRAJ+UPQCt4v5wFjp4kOkn0//UBfPhhji8J9aGx7xJpoZVBbtul9sijU6nRnmAbkYYIgKinUEkGPj43Jf1rwKWPLc6TtY0CHJZiVXMfhKRrEJHdOg4AYrz03B452W0GJHLPTyB+Wf6hHKyZphtBjAf2se5ZV+jmcunjwKZtRCkOOrEygJ10FwWwkJkvgpnTnKPw2koRMO3Gq962NFNytldEfjziaSzC4=","ak.pv":"18","ak.dpoabenc":"","ak.tf":i};if(""!==t)_["ak.ruds"]=t;var o={i:!1,av:function(e){var t="http.initiator";if(e&&(!e[t]||"spa_hard"===e[t]))_["ak.feo"]=void 0!==a.aFeoApplied?1:0,BOOMR.addVar(_)},rv:function(){var a=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t","ak.tf"];BOOMR.removeVar(a)}};BOOMR.plugins.AK={akVars:_,akDNSPreFetchDomain:n,init:function(){if(!o.i){var a=BOOMR.subscribe;a("before_beacon",o.av,null,null),a("onbeacon",o.rv,null,null),o.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head>
  <body class="fb single single-article amp-geo-pending" data-n-head="class">
    <amp-geo layout="nodisplay">
      <script type="application/json">
      {
        "ISOCountryGroups": {
          "eu": ["at", "be", "bg", "cy", "cz", "de", "dk", "ee", "es", "fi", "fr", "gb", "gr", "hr", "hu", "ie", "it", "lt", "lu", "lv", "mt", "nl", "pl", "pt", "ro", "se", "si", "sk"]
        }
      }
      </script>
    </amp-geo>
    <div data-server-rendered="true" id="__nuxt"><div id="__layout"><div id="wrapper" class="wrapper"><header class="site-header nav-closed" data-v-29d3ecd4><!----> <div class="site-header-inner" data-v-a16ad268 data-v-29d3ecd4><div class="branding" data-v-a16ad268><a href="/" data-name="logo" class="logo global-nav-item" data-v-a16ad268><img src="//static.foxtv.com/static/orion/img/core/s/logos/fts-ocala-gainesville-a.svg" alt="FOX 51 Gainesville" class="logo-full" data-v-a16ad268> <img src="//static.foxtv.com/static/orion/img/core/s/logos/fts-ocala-gainesville-b.svg" alt="FOX 51 Gainesville" class="logo-mini" data-v-a16ad268></a> <!----></div> <div class="nav-row" data-v-a16ad268><div class="primary-nav tablet-desktop" data-v-a16ad268><nav id="main-nav" data-v-a16ad268><ul data-v-a16ad268><li class="menu-live" data-v-a16ad268><a href="/live" data-name="Live" class="global-nav-item" data-v-a16ad268><span data-v-a16ad268>Live</span></a></li><li class="menu-news" data-v-a16ad268><a href="/news" data-name="News" class="global-nav-item" data-v-a16ad268><span data-v-a16ad268>News</span></a></li><li class="menu-weather" data-v-a16ad268><a href="/weather" data-name="Weather" class="global-nav-item" data-v-a16ad268><span data-v-a16ad268>Weather</span></a></li><li class="menu-community" data-v-a16ad268><a href="/tag/entertainment/community" data-name="Community" class="global-nav-item" data-v-a16ad268><span data-v-a16ad268>Community</span></a></li><li class="menu-contests" data-v-a16ad268><a href="/contests" data-name="Contests" class="global-nav-item" data-v-a16ad268><span data-v-a16ad268>Contests</span></a></li> <li class="menu-more" data-v-a16ad268><a href="#" data-name="More" class="js-menu-toggle global-nav-item" data-v-a16ad268>More</a></li></ul></nav></div> <div class="meta" data-v-a16ad268><span data-v-54cc023d data-v-a16ad268><!----> <!----> <!----> <button class="button-reset watch-live mobile" data-v-54cc023d><a href="/live" data-name="Watch Live" class="global-nav-item" data-v-54cc023d>Watch Live</a></button></span> <div class="search-toggle tablet-desktop" data-v-a16ad268><a href="#" data-name="Search" class="js-focus-search global-nav-item" data-v-a16ad268>Expand / Collapse search</a></div> <div class="menu mobile" data-v-a16ad268><a href="#" data-name="Search" class="js-menu-toggle global-nav-item" data-v-a16ad268>☰</a></div></div></div></div> <div class="expandable-nav" data-v-29d3ecd4><div class="inner" data-v-29d3ecd4><div class="search"><div class="search-wrap"><form autocomplete="off" action="/search" method="get"><fieldset><label for="search-site" class="label">Search site</label> <input id="search-site" type="text" placeholder="Search for keywords" name="q" onblur onfocus autocomplete="off" value="" class="resp_site_search"> <input type="hidden" name="ss" value="fb"> <input type="submit" value="Search" class="resp_site_submit"></fieldset></form></div></div></div> <div class="section-nav" data-v-29d3ecd4><div class="inner"><nav class="menu-regional-news"><h6 class="nav-title"><a href="/local-news" data-name="Regional News" class="global-nav-item">Regional News</a></h6> <ul><li class="nav-item"><a href="https://www.fox35orlando.com/">Orlando News - FOX 35 Orlando</a></li><li class="nav-item"><a href="https://www.fox13news.com/">Tampa News - FOX 13 News</a></li><li class="nav-item"><a href="https://www.fox5atlanta.com/">Atlanta News - FOX 5 Atlanta</a></li></ul></nav><nav class="menu-weather"><h6 class="nav-title"><a href="/weather" data-name="Weather" class="global-nav-item">Weather</a></h6> <ul><li class="nav-item"><a href="/weather">Interactive Radar</a></li><li class="nav-item"><a href="/weather-alerts">Weather Alerts</a></li><li class="nav-item"><a href="/7-day-forecast">7-Day Forecast</a></li><li class="nav-item"><a href="/hour-by-hour-forecast">Hour-by-Hour Forecast</a></li></ul></nav><nav class="menu-money"><h6 class="nav-title"><a href="https://www.wogx.com/money" data-name="Money" class="global-nav-item">Money</a></h6> <ul><li class="nav-item"><a href="/tag/business/personal-finance">Personal Finance</a></li><li class="nav-item"><a href="/tag/money/us-economy">The Economy</a></li><li class="nav-item"><a href="/tag/business/small-business">Small Business</a></li></ul></nav><nav class="menu-tv-listings"><h6 class="nav-title"><a href="/whatsonfox" data-name="TV Listings" class="global-nav-item">TV Listings</a></h6> <ul><li class="nav-item"><a href="/whatsonfox">What’s on FOX 51</a></li><li class="nav-item"><a href="https://www.fox.com/entertainment/">Watch FOX Shows</a></li></ul></nav><nav class="menu-about-us"><h6 class="nav-title"><a href="/about" data-name="About Us" class="global-nav-item">About Us</a></h6> <ul><li class="nav-item"><a href="/advertise">Advertise with Us</a></li><li class="nav-item"><a href="/person/all">Personalities</a></li><li class="nav-item"><a href="/tag/entertainment/community">Community Events</a></li><li class="nav-item"><a href="/about">Contact Us</a></li><li class="nav-item"><a href="https://www.wogx.com/jobs">Jobs at FOX 51</a></li><li class="nav-item"><a href="/closed-captioning">Closed Captioning</a></li><li class="nav-item"><a href="https://www.fox35orlando.com/fcc-online-public-file">FCC Public File</a></li><li class="nav-item"><a href="https://www.wogx.com/fcc-applications">FCC Applications</a></li></ul></nav><nav class="menu-news-tips"><h6 class="nav-title"><a href="/about" data-name="News Tips" class="global-nav-item">News Tips</a></h6> <ul><li class="nav-item"><a href="/about">Call: (407) 741-5027</a></li><li class="nav-item"><a href="/about">Email: FOX35Tips@fox.com</a></li></ul></nav></div></div></div> <iframe id="xd-channel-fts-iframe" src="https://my.foxtv.com/xd-channel.html" role="presentation" data-v-29d3ecd4></iframe></header> <div class="page"><div class="pre-content"><div data-v-6e1c7e98></div> <div class="pre-content-components"><div><div class="ad-container tablet"><div data-ad-pos="tablet" data-ad-size="728x90" class="ad gpt min-height-ad"></div> <!----></div><div class="ad-container desktop"><div data-ad-pos="desktop" data-ad-size="728x90,970x66,970x250" class="ad gpt min-height-ad"></div> <!----></div><div class="ad-container mobile"><div data-ad-pos="mobile" data-ad-size="" class="ad gpt min-height-ad"></div> <!----></div></div></div></div> <div class="page-content"><main class="main-content"><article id="02d9edd9-112e-5309-af50-2cc0666055be" comments="[object Object]" origination_station="WOFL" class="article-wrap"><header lastModifiedDate="2022-05-11T23:18:06-04:00" class="article-header" data-v-d6212dd0><div class="meta" data-v-d6212dd0><!----></div> <h1 class="headline" data-v-d6212dd0>Low pressure lingering off East Coast brings gusty winds, high surf, rip currents and coastal flooding</h1> <div class="article-meta article-meta-upper" data-v-d6212dd0><div class="author-byline" data-v-d6212dd0><strong>By </strong>Brian Donegan<!----></div> <div class="article-date" data-v-d6212dd0><strong data-v-d6212dd0>Published</strong> <time data-v-d6212dd0>May 11, 2022 9:41PM</time></div> <!----> <div class="article-updated" data-v-d6212dd0><a href="/tag/us/fl/marion-county/ocala" data-v-d6212dd0>Ocala</a></div> <div class="article-updated" data-v-d6212dd0><a href="https://www.foxweather.com" data-v-d6212dd0>FOX Weather</a></div></div> <div class="article-meta article-meta-lower" data-v-d6212dd0><div class="article-social" data-v-d6212dd0><div class="social-icons"><ul><li class="fb"><a href="#"><span>Facebook</span></a></li> <li class="tw"><a href="#"><span>Twitter</span></a></li> <!----> <li class="print"><a href="#"><span>Print</span></a></li> <li class="email"><a href="#">Email</a></li></ul></div></div></div></header> <!----> <div class="article-content-wrap sticky-columns"><div class="article-content"><!----> <div class="article-body"><!----> <!----> <div class="featured featured-video video-ct"><div class="contain"><div class="control"><a href="#" class="top"></a> <a href="#" class="close"></a></div> <!----> <div class="info"><div class="caption"><h4 class="title">Weather Forecast: May 11, 2022</h4> <p>FOX 35 Storm Team Meteorologist Brooks Garner has the latest on the weather in Central Florida.</p></div></div></div></div> <!----><!----> <!----> <p>A pesky low-pressure system that developed off the East Coast over Mother&apos;s Day weekend continues to meander in the western Atlantic Ocean, creating gusty winds, high surf, rip currents and coastal flooding from the mid-Atlantic southward to Florida.</p> <!----><!----> <!----> <p>The jet stream is currently parked well to the north, so instead of drifting out to sea, this system will actually retreat southwestward in the direction of the southeastern U.S. during the second half of this week.</p> <div data-uid="fts-ar-16" class="vendor-unit"></div> <div data-ad-pos="inread" data-ad-size="1x1" class="ad gpt"></div><!----> <!----> <p>A high-pressure system is also located over the Canadian Maritimes. The clockwise winds around this high are teaming up with the counterclockwise winds around the low-pressure system near the Eastern Seaboard, generating persistent northeasterly onshore winds.</p> <!----><div class="ad-container mobile "><div data-ad-pos="mobile" data-ad-size="300x250" class="ad gpt ad-h-250"></div> <!----></div> <!----> <p>These stronger winds will produce high surf and rip currents along much of the East Coast through the end of the week, including as far south as the Atlantic coast of Florida.</p> <!----><!----> <!----> <div><div data-unit-credible=";;" data-in-article="true" class="credible"></div></div> <!----><!----> <!----> <p><a href="https://www.foxweather.com/learn/how-to-watch-fox-weather-on-tv" target="_blank"><strong><u>HOW TO WATCH FOX WEATHER ON TV</u></strong></a></p> <!----><!----> <!----> <p>While the coastal flooding threat is starting to diminish, at least minor coastal flooding could linger at times of high tide through Thursday evening in the Virginia Tidewater and the eastern Carolinas in cities such as Norfolk and Virginia Beach in Virginia, Wilmington in North Carolina and Charleston in South Carolina.</p> <!----><!----> <!----> <p>Large, persistent waves will cause severe beach erosion as well.</p> <!----><!----> <!----> <p>One of the hardest-hit areas has been the Outer Banks of North Carolina, where widespread coastal flooding on Tuesday forced the <a href="https://twitter.com/NCDOT_NC12/status/1523999754178420736" target="_blank"><u>closure of portions of N.C. 12</u></a> on Hatteras Island, according to the North Carolina Department of Transportation. The highway <a href="https://twitter.com/NCDOT_NC12/status/1524362289423560705" target="_blank"><u>remained closed</u></a> as of Wednesday morning.</p> <!----><!----> <!----> <p>Additionally, the high surf caused two beachfront homes to collapse in the Outer Banks. An unoccupied home in Rodanthe, North Carolina, <a href="https://www.nps.gov/caha/learn/news/another-house-in-rodanthe-nc-collapses-at-cape-hatteras-national-seashore.htm" target="_blank" rel="nofollow"><u>fell into the surf</u></a> Tuesday morning, according to officials with Cape Hatteras National Seashore National Park. A second unoccupied home <a href="https://www.nps.gov/caha/learn/news/second-house-collapses-at-cape-hatteras-national-seashore.htm" target="_blank" rel="nofollow"><u>collapsed a short time later</u></a>, NPS officials said.&#xA0;</p> <!----><!----> <!----> <p>Finally, by Thursday night or Friday, this low-pressure system will begin to retreat southwestward toward the southeastern U.S. That will increase the chance of rain across portions of the Southeast from Friday into the weekend.</p> <!----><!----> <!----> <p>If you have beach plans, you&apos;re advised to use caution because of the threat of rip currents. According to the National Weather Service, an <a href="https://www.weather.gov/hazstat/" target="_blank"><u>average of 60 people</u></a> are killed by rip currents each year in the U.S. So far this year, rip currents have already been blamed for <a href="https://www.weather.gov/safety/ripcurrent-fatalities" target="_blank"><u>14 deaths</u></a>.</p> <!----><!----> <!----> <p>Many beaches use color-coded flags to warn visitors of the day&#x2019;s rip current risk.</p> <!----><!----> <!----> <p>If you see a green flag, strong rip currents are not expected that day, so you should be able to swim safely. However, beware of the yellow and red flags. A yellow flag means there is a moderate risk of strong rip currents, while a red flag indicates a high risk. Take extreme caution when entering the water if a yellow or red flag is posted on the beach.</p> <!----><!----> <!----> <p>You can find NOAA&#x2019;s official rip current forecasts <a href="https://www.weather.gov/safety/ripcurrent-forecasts" target="_blank"><u>at this link</u></a>.</p> <!----><!----> <!----> <h2><strong>Subtropical development not ruled out</strong></h2> <!----><!----> <!----> <p>It&apos;s still not completely ruled out that this low-pressure system meandering off the East Coast could briefly become a subtropical depression or subtropical storm before it moves inland over the Southeast late Thursday or Friday. A storm designated as subtropical means it has characteristics of both a tropical and a non-tropical cyclone (a low-pressure system that you would typically find over land in the U.S.).</p> <!----><!----> <!----> <p>The National Hurricane Center issues <a href="https://www.foxweather.com/learn/hurricane-tropical-storm-watch-vs-warning-why-its-important-to-know-the-difference" target="_blank"><u>routine advisories</u></a> for subtropical depressions and subtropical storms, just as it does for tropical depressions, tropical storms and hurricanes.</p> <!----><!----> <!----> <p>The odds of this happening are very low, but in the outside chance it develops into a subtropical storm with winds of at least 40 mph, it would earn the name &quot;Alex,&quot; the first on the <a href="https://www.foxweather.com/extreme-weather/atlantic-hurricane-season-names-2022" target="_blank"><u>naming list for the 2022 Atlantic hurricane season</u></a>.</p> <!----><!----> <!----> <p><a href="https://listen.foxaud.io/foxweather?sid=fwx.internallink" target="_blank"><strong><u>CLICK HERE TO GET THE FOX WEATHER UPDATE PODCAST</u></strong></a></p> <!----><!----> <!----> <p>Although hurricane season doesn&apos;t officially begin until June 1, the <a href="https://www.foxweather.com/learn/why-atlantic-hurricane-season-runs-june-to-november" target="_blank"><u>past seven seasons have all spawned at least one named storm</u></a> before that date.</p> <!----><!----> <!----> <p>Regardless of what this system is called (or not called), the impacts along the East Coast will be the same as we outlined above.</p> <!----><!----> <div class="ad-container mobile "><div data-ad-pos="mobile" data-ad-size="300x251" class="ad gpt ad-h-251"></div> <p class="advert-txt">Advertisement</p></div> <p><a href="https://www.foxweather.com/weather-news/east-coast-storm-wind-high-surf-rip-currents-coastal-flooding-may" target="_blank"><strong>GET UPDATES ON THIS STORY AT FOXWEATHER.COM</strong></a></p> <!---->  <div data-uid="fts-ar-17" class="vendor-unit"></div></div> <!----></div> <aside class="sidebar sidebar-primary"><div class="sticky-region"><div class="sidebar-columns"><div><div class="ad-container tablet"><div data-ad-pos="tablet" data-ad-size="300x600,300x250" class="ad gpt min-height-ad"></div> <!----></div><div class="ad-container desktop"><div data-ad-pos="desktop" data-ad-size="300x600,300x250" class="ad gpt min-height-ad"></div> <!----></div><div class="ad-container mobile"><div data-ad-pos="mobile" data-ad-size="" class="ad gpt min-height-ad"></div> <!----></div></div><section class="collection collection-river" data-v-a14e8d96><header class="heading" data-v-a14e8d96><h2 class="title" data-v-a14e8d96>
      Latest News
    </h2> <!----></header> <div class="content article-list" data-v-a14e8d96><article class="article story-1" data-v-a14e8d96><!----> <div class="m"><a href="/news/passenger-with-no-experience-lands-small-plane-in-florida-after-pilot-has-medical-emergency"><div class="responsive-image__container" data-v-0acd4584><div class="responsive-image__lazy-container" style="background-image:url('https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/592/333/GCT-00001.jpg?ve=1&amp;tl=1');" data-v-0acd4584><img alt="Passenger with no experience lands small plane in Florida after pilot has medical emergency" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/32/18/GCT-00001.jpg?ve=1&amp;tl=1" data-src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/592/333/GCT-00001.jpg?ve=1&amp;tl=1" data-srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/1184/666/GCT-00001.jpg?ve=1&amp;tl=1 2x" style="background:rgba(0,0,0,0);width:592px;margin:auto;height:0;padding-top:56.25%;" data-v-0acd4584></div> <noscript data-v-0acd4584><picture class="responsive-image__picture" data-v-0acd4584><source media="(max-width: 767px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/320/180/GCT-00001.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/640/360/GCT-00001.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 1024px) and (max-width: 1279px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/360/203/GCT-00001.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/720/406/GCT-00001.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 768px) and (max-width: 1024px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/413/232/GCT-00001.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/826/464/GCT-00001.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 1280px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/592/333/GCT-00001.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/1184/666/GCT-00001.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584> <img alt="Passenger with no experience lands small plane in Florida after pilot has medical emergency" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/592/333/GCT-00001.jpg?ve=1&amp;tl=1" data-v-0acd4584></picture></noscript></div> <!----></a></div> <div class="info"><header class="info-header"><div class="meta"><!----></div> <h3 class="title"><a href="/news/passenger-with-no-experience-lands-small-plane-in-florida-after-pilot-has-medical-emergency">Passenger with no experience lands small plane in Florida after pilot has medical emergency</a></h3></header> <!----> <!----> <!----></div></article><article class="article story-2" data-v-a14e8d96><!----> <div class="m"><a href="/news/terrifying-photo-shows-dozens-of-florida-alligators-glowing-eyes-at-night"><div class="responsive-image__container" data-v-0acd4584><div class="responsive-image__lazy-container" style="background-image:url('https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/592/333/de9366b5-21fca262-Image-from-iOS-1.jpg?ve=1&amp;tl=1');" data-v-0acd4584><img alt="Photos show dozens of Florida alligators with 'glowing' eyes at night" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/32/18/de9366b5-21fca262-Image-from-iOS-1.jpg?ve=1&amp;tl=1" data-src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/592/333/de9366b5-21fca262-Image-from-iOS-1.jpg?ve=1&amp;tl=1" data-srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/1184/666/de9366b5-21fca262-Image-from-iOS-1.jpg?ve=1&amp;tl=1 2x" style="background:rgba(0,0,0,0);width:592px;margin:auto;height:0;padding-top:56.25%;" data-v-0acd4584></div> <noscript data-v-0acd4584><picture class="responsive-image__picture" data-v-0acd4584><source media="(max-width: 767px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/320/180/de9366b5-21fca262-Image-from-iOS-1.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/640/360/de9366b5-21fca262-Image-from-iOS-1.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 1024px) and (max-width: 1279px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/360/203/de9366b5-21fca262-Image-from-iOS-1.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/720/406/de9366b5-21fca262-Image-from-iOS-1.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 768px) and (max-width: 1024px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/413/232/de9366b5-21fca262-Image-from-iOS-1.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/826/464/de9366b5-21fca262-Image-from-iOS-1.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 1280px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/592/333/de9366b5-21fca262-Image-from-iOS-1.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/1184/666/de9366b5-21fca262-Image-from-iOS-1.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584> <img alt="Photos show dozens of Florida alligators with 'glowing' eyes at night" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/592/333/de9366b5-21fca262-Image-from-iOS-1.jpg?ve=1&amp;tl=1" data-v-0acd4584></picture></noscript></div> <!----></a></div> <div class="info"><header class="info-header"><div class="meta"><!----></div> <h3 class="title"><a href="/news/terrifying-photo-shows-dozens-of-florida-alligators-glowing-eyes-at-night">Photos show dozens of Florida alligators with 'glowing' eyes at night</a></h3></header> <!----> <!----> <!----></div></article><article class="article story-3" data-v-a14e8d96><!----> <div class="m"><a href="/news/massive-ocean-storm-to-bring-life-threatening-rip-currents-to-florida-beaches"><div class="responsive-image__container" data-v-0acd4584><div class="responsive-image__lazy-container" style="background-image:url('https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/592/333/rip-currents-1.jpg?ve=1&amp;tl=1');" data-v-0acd4584><img alt="Massive ocean storm to bring life-threatening rip currents to Florida beaches" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/32/18/rip-currents-1.jpg?ve=1&amp;tl=1" data-src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/592/333/rip-currents-1.jpg?ve=1&amp;tl=1" data-srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/1184/666/rip-currents-1.jpg?ve=1&amp;tl=1 2x" style="background:rgba(0,0,0,0);width:592px;margin:auto;height:0;padding-top:56.25%;" data-v-0acd4584></div> <noscript data-v-0acd4584><picture class="responsive-image__picture" data-v-0acd4584><source media="(max-width: 767px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/320/180/rip-currents-1.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/640/360/rip-currents-1.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 1024px) and (max-width: 1279px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/360/203/rip-currents-1.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/720/406/rip-currents-1.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 768px) and (max-width: 1024px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/413/232/rip-currents-1.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/826/464/rip-currents-1.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 1280px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/592/333/rip-currents-1.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/1184/666/rip-currents-1.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584> <img alt="Massive ocean storm to bring life-threatening rip currents to Florida beaches" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/592/333/rip-currents-1.jpg?ve=1&amp;tl=1" data-v-0acd4584></picture></noscript></div> <!----></a></div> <div class="info"><header class="info-header"><div class="meta"><!----></div> <h3 class="title"><a href="/news/massive-ocean-storm-to-bring-life-threatening-rip-currents-to-florida-beaches">Massive ocean storm to bring life-threatening rip currents to Florida beaches</a></h3></header> <!----> <!----> <!----></div></article><article class="article story-4" data-v-a14e8d96><!----> <div class="m"><a href="/news/florida-teens-can-work-out-at-planet-fitness-for-free-all-summer"><div class="responsive-image__container" data-v-0acd4584><div class="responsive-image__lazy-container" style="background-image:url('https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/592/333/f783f2b3-planet-fitness.jpg?ve=1&amp;tl=1');" data-v-0acd4584><img alt="Florida teens can work out at Planet Fitness for free all summer" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/32/18/f783f2b3-planet-fitness.jpg?ve=1&amp;tl=1" data-src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/592/333/f783f2b3-planet-fitness.jpg?ve=1&amp;tl=1" data-srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/1184/666/f783f2b3-planet-fitness.jpg?ve=1&amp;tl=1 2x" style="background:rgba(0,0,0,0);width:592px;margin:auto;height:0;padding-top:56.25%;" data-v-0acd4584></div> <noscript data-v-0acd4584><picture class="responsive-image__picture" data-v-0acd4584><source media="(max-width: 767px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/320/180/f783f2b3-planet-fitness.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/640/360/f783f2b3-planet-fitness.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 1024px) and (max-width: 1279px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/360/203/f783f2b3-planet-fitness.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/720/406/f783f2b3-planet-fitness.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 768px) and (max-width: 1024px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/413/232/f783f2b3-planet-fitness.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/826/464/f783f2b3-planet-fitness.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 1280px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/592/333/f783f2b3-planet-fitness.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/1184/666/f783f2b3-planet-fitness.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584> <img alt="Florida teens can work out at Planet Fitness for free all summer" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/592/333/f783f2b3-planet-fitness.jpg?ve=1&amp;tl=1" data-v-0acd4584></picture></noscript></div> <!----></a></div> <div class="info"><header class="info-header"><div class="meta"><!----></div> <h3 class="title"><a href="/news/florida-teens-can-work-out-at-planet-fitness-for-free-all-summer">Florida teens can work out at Planet Fitness for free all summer</a></h3></header> <!----> <!----> <!----></div></article><article class="article story-5" data-v-a14e8d96><!----> <div class="m"><a href="/news/groups-sue-epa-over-water-quality-catastrophic-manatee-deaths-in-florida"><div class="responsive-image__container" data-v-0acd4584><div class="responsive-image__lazy-container" style="background-image:url('https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/592/333/manatee-us-fish-and-wildlife.jpg?ve=1&amp;tl=1');" data-v-0acd4584><img alt="Groups sue EPA over water quality, 'catastrophic' manatee deaths in Florida" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/32/18/manatee-us-fish-and-wildlife.jpg?ve=1&amp;tl=1" data-src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/592/333/manatee-us-fish-and-wildlife.jpg?ve=1&amp;tl=1" data-srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/1184/666/manatee-us-fish-and-wildlife.jpg?ve=1&amp;tl=1 2x" style="background:rgba(0,0,0,0);width:592px;margin:auto;height:0;padding-top:56.25%;" data-v-0acd4584></div> <noscript data-v-0acd4584><picture class="responsive-image__picture" data-v-0acd4584><source media="(max-width: 767px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/320/180/manatee-us-fish-and-wildlife.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/640/360/manatee-us-fish-and-wildlife.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 1024px) and (max-width: 1279px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/360/203/manatee-us-fish-and-wildlife.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/720/406/manatee-us-fish-and-wildlife.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 768px) and (max-width: 1024px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/413/232/manatee-us-fish-and-wildlife.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/826/464/manatee-us-fish-and-wildlife.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 1280px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/592/333/manatee-us-fish-and-wildlife.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/1184/666/manatee-us-fish-and-wildlife.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584> <img alt="Groups sue EPA over water quality, 'catastrophic' manatee deaths in Florida" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/592/333/manatee-us-fish-and-wildlife.jpg?ve=1&amp;tl=1" data-v-0acd4584></picture></noscript></div> <!----></a></div> <div class="info"><header class="info-header"><div class="meta"><!----></div> <h3 class="title"><a href="/news/groups-sue-epa-over-water-quality-catastrophic-manatee-deaths-in-florida">Groups sue EPA over water quality, 'catastrophic' manatee deaths in Florida</a></h3></header> <!----> <!----> <!----></div></article></div></section><section class="collection collection-trending" data-v-716938ab><header class="heading" data-v-716938ab><h3 class="title" data-v-716938ab>Trending</h3></header> <div class="content article-list" data-v-716938ab><article class="article story-1" data-v-716938ab><!----> <div class="m"><a href="/news/kissimmee-target-shooting-deputies-shot-into-moving-car-didnt-id-themselves-attorneys-say"><div class="responsive-image__container" data-v-0acd4584><div class="responsive-image__lazy-container" style="background-image:url('https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/04/100/56/WOFL-Kissimmee-Target-shooting-4.jpg?ve=1&amp;tl=1');" data-v-0acd4584><img alt="Kissimmee Target shooting: Deputies shot into car, didn't ID themselves, attorneys say" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/04/32/18/WOFL-Kissimmee-Target-shooting-4.jpg?ve=1&amp;tl=1" data-src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/04/100/56/WOFL-Kissimmee-Target-shooting-4.jpg?ve=1&amp;tl=1" data-srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/04/200/112/WOFL-Kissimmee-Target-shooting-4.jpg?ve=1&amp;tl=1 2x" style="background:rgba(0,0,0,0);width:100px;margin:auto;height:0;padding-top:56.00000000000001%;" data-v-0acd4584></div> <noscript data-v-0acd4584><picture class="responsive-image__picture" data-v-0acd4584><source media="(min-width: 320px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/04/100/56/WOFL-Kissimmee-Target-shooting-4.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/04/200/112/WOFL-Kissimmee-Target-shooting-4.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584> <img alt="Kissimmee Target shooting: Deputies shot into car, didn't ID themselves, attorneys say" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/04/100/56/WOFL-Kissimmee-Target-shooting-4.jpg?ve=1&amp;tl=1" data-v-0acd4584></picture></noscript></div></a></div> <div class="info"><header class="info-header"><div class="meta"><!----></div> <h4 class="title"><a href="/news/kissimmee-target-shooting-deputies-shot-into-moving-car-didnt-id-themselves-attorneys-say">Kissimmee Target shooting: Deputies shot into car, didn't ID themselves, attorneys say</a></h4></header> <!----></div></article><article class="article story-2" data-v-716938ab><!----> <div class="m"><a href="/news/more-people-surrendering-their-pets-due-to-relocation-concerns-florida-animal-shelters-say"><div class="responsive-image__container" data-v-0acd4584><div class="responsive-image__lazy-container" style="background-image:url('https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/100/56/WOFL-Orange-County-Animal-Services-B.jpg?ve=1&amp;tl=1');" data-v-0acd4584><img alt="More people surrendering their pets due to relocation concerns, Florida animal shelters say" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/32/18/WOFL-Orange-County-Animal-Services-B.jpg?ve=1&amp;tl=1" data-src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/100/56/WOFL-Orange-County-Animal-Services-B.jpg?ve=1&amp;tl=1" data-srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/200/112/WOFL-Orange-County-Animal-Services-B.jpg?ve=1&amp;tl=1 2x" style="background:rgba(0,0,0,0);width:100px;margin:auto;height:0;padding-top:56.00000000000001%;" data-v-0acd4584></div> <noscript data-v-0acd4584><picture class="responsive-image__picture" data-v-0acd4584><source media="(min-width: 320px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/100/56/WOFL-Orange-County-Animal-Services-B.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/200/112/WOFL-Orange-County-Animal-Services-B.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584> <img alt="More people surrendering their pets due to relocation concerns, Florida animal shelters say" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/100/56/WOFL-Orange-County-Animal-Services-B.jpg?ve=1&amp;tl=1" data-v-0acd4584></picture></noscript></div></a></div> <div class="info"><header class="info-header"><div class="meta"><!----></div> <h4 class="title"><a href="/news/more-people-surrendering-their-pets-due-to-relocation-concerns-florida-animal-shelters-say">More people surrendering their pets due to relocation concerns, Florida animal shelters say</a></h4></header> <!----></div></article><article class="article story-3" data-v-716938ab><!----> <div class="m"><a href="/news/boeing-ready-to-try-again-starliner-to-space-station"><div class="responsive-image__container" data-v-0acd4584><div class="responsive-image__lazy-container" style="background-image:url('https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/100/56/Boeing-Starliner-hoist.jpg?ve=1&amp;tl=1');" data-v-0acd4584><img alt="Boeing says it has resolved Starliner issue partly caused by Florida humidity" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/32/18/Boeing-Starliner-hoist.jpg?ve=1&amp;tl=1" data-src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/100/56/Boeing-Starliner-hoist.jpg?ve=1&amp;tl=1" data-srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/200/112/Boeing-Starliner-hoist.jpg?ve=1&amp;tl=1 2x" style="background:rgba(0,0,0,0);width:100px;margin:auto;height:0;padding-top:56.00000000000001%;" data-v-0acd4584></div> <noscript data-v-0acd4584><picture class="responsive-image__picture" data-v-0acd4584><source media="(min-width: 320px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/100/56/Boeing-Starliner-hoist.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/200/112/Boeing-Starliner-hoist.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584> <img alt="Boeing says it has resolved Starliner issue partly caused by Florida humidity" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/100/56/Boeing-Starliner-hoist.jpg?ve=1&amp;tl=1" data-v-0acd4584></picture></noscript></div></a></div> <div class="info"><header class="info-header"><div class="meta"><!----></div> <h4 class="title"><a href="/news/boeing-ready-to-try-again-starliner-to-space-station">Boeing says it has resolved Starliner issue partly caused by Florida humidity</a></h4></header> <!----></div></article><article class="article story-4" data-v-716938ab><!----> <div class="m"><a href="/news/first-look-inside-guardians-of-galaxy-rollercoaster-at-walt-disney-worlds-epcot"><div class="responsive-image__container" data-v-0acd4584><div class="responsive-image__lazy-container" style="background-image:url('https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/100/56/Guardians-of-Galaxy-Comic-Rewind-Disney-Photo-6.jpg?ve=1&amp;tl=1');" data-v-0acd4584><img alt="First look: Inside new 'Guardians of Galaxy' roller coaster at Walt Disney World's EPCOT" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/32/18/Guardians-of-Galaxy-Comic-Rewind-Disney-Photo-6.jpg?ve=1&amp;tl=1" data-src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/100/56/Guardians-of-Galaxy-Comic-Rewind-Disney-Photo-6.jpg?ve=1&amp;tl=1" data-srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/200/112/Guardians-of-Galaxy-Comic-Rewind-Disney-Photo-6.jpg?ve=1&amp;tl=1 2x" style="background:rgba(0,0,0,0);width:100px;margin:auto;height:0;padding-top:56.00000000000001%;" data-v-0acd4584></div> <noscript data-v-0acd4584><picture class="responsive-image__picture" data-v-0acd4584><source media="(min-width: 320px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/100/56/Guardians-of-Galaxy-Comic-Rewind-Disney-Photo-6.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/200/112/Guardians-of-Galaxy-Comic-Rewind-Disney-Photo-6.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584> <img alt="First look: Inside new 'Guardians of Galaxy' roller coaster at Walt Disney World's EPCOT" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/100/56/Guardians-of-Galaxy-Comic-Rewind-Disney-Photo-6.jpg?ve=1&amp;tl=1" data-v-0acd4584></picture></noscript></div></a></div> <div class="info"><header class="info-header"><div class="meta"><!----></div> <h4 class="title"><a href="/news/first-look-inside-guardians-of-galaxy-rollercoaster-at-walt-disney-worlds-epcot">First look: Inside new 'Guardians of Galaxy' roller coaster at Walt Disney World's EPCOT</a></h4></header> <!----></div></article><article class="article story-5" data-v-716938ab><!----> <div class="m"><a href="/news/official-students-hung-dead-gutted-shark-in-courtyard-of-florida-high-school"><div class="responsive-image__container" data-v-0acd4584><div class="responsive-image__lazy-container" style="background-image:url('https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/100/56/WOFL-Shark-found-at-St.-Johns-County-School-District-High-School.jpg?ve=1&amp;tl=1');" data-v-0acd4584><img alt="Dead shark gutted and hung at Florida high school; investigation underway, officials say" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/32/18/WOFL-Shark-found-at-St.-Johns-County-School-District-High-School.jpg?ve=1&amp;tl=1" data-src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/100/56/WOFL-Shark-found-at-St.-Johns-County-School-District-High-School.jpg?ve=1&amp;tl=1" data-srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/200/112/WOFL-Shark-found-at-St.-Johns-County-School-District-High-School.jpg?ve=1&amp;tl=1 2x" style="background:rgba(0,0,0,0);width:100px;margin:auto;height:0;padding-top:56.00000000000001%;" data-v-0acd4584></div> <noscript data-v-0acd4584><picture class="responsive-image__picture" data-v-0acd4584><source media="(min-width: 320px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/100/56/WOFL-Shark-found-at-St.-Johns-County-School-District-High-School.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/200/112/WOFL-Shark-found-at-St.-Johns-County-School-District-High-School.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584> <img alt="Dead shark gutted and hung at Florida high school; investigation underway, officials say" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/05/100/56/WOFL-Shark-found-at-St.-Johns-County-School-District-High-School.jpg?ve=1&amp;tl=1" data-v-0acd4584></picture></noscript></div></a></div> <div class="info"><header class="info-header"><div class="meta"><!----></div> <h4 class="title"><a href="/news/official-students-hung-dead-gutted-shark-in-courtyard-of-florida-high-school">Dead shark gutted and hung at Florida high school; investigation underway, officials say</a></h4></header> <!----></div></article></div></section><div><div class="ad-container tablet"><div data-ad-pos="tablet" data-ad-size="300x251" class="ad gpt min-height-ad"></div> <!----></div><div class="ad-container desktop"><div data-ad-pos="desktop" data-ad-size="300x251" class="ad gpt min-height-ad"></div> <!----></div><div class="ad-container mobile"><div data-ad-pos="mobile" data-ad-size="300x251" class="ad gpt min-height-ad"></div> <!----></div></div></div></div></aside></div></article></main></div></div> <footer class="site-footer" data-v-edc3a70c><!----> <div class="section-nav footer-upper" data-v-edc3a70c><div class="inner"><nav class="menu-regional-news"><h6 class="nav-title"><a href="/local-news" data-name="Regional News" class="global-nav-item">Regional News</a></h6> <ul><li class="nav-item"><a href="https://www.fox35orlando.com/">Orlando News - FOX 35 Orlando</a></li><li class="nav-item"><a href="https://www.fox13news.com/">Tampa News - FOX 13 News</a></li><li class="nav-item"><a href="https://www.fox5atlanta.com/">Atlanta News - FOX 5 Atlanta</a></li></ul></nav><nav class="menu-weather"><h6 class="nav-title"><a href="/weather" data-name="Weather" class="global-nav-item">Weather</a></h6> <ul><li class="nav-item"><a href="/weather">Interactive Radar</a></li><li class="nav-item"><a href="/weather-alerts">Weather Alerts</a></li><li class="nav-item"><a href="/7-day-forecast">7-Day Forecast</a></li><li class="nav-item"><a href="/hour-by-hour-forecast">Hour-by-Hour Forecast</a></li></ul></nav><nav class="menu-money"><h6 class="nav-title"><a href="https://www.wogx.com/money" data-name="Money" class="global-nav-item">Money</a></h6> <ul><li class="nav-item"><a href="/tag/business/personal-finance">Personal Finance</a></li><li class="nav-item"><a href="/tag/money/us-economy">The Economy</a></li><li class="nav-item"><a href="/tag/business/small-business">Small Business</a></li></ul></nav><nav class="menu-tv-listings"><h6 class="nav-title"><a href="/whatsonfox" data-name="TV Listings" class="global-nav-item">TV Listings</a></h6> <ul><li class="nav-item"><a href="/whatsonfox">What’s on FOX 51</a></li><li class="nav-item"><a href="https://www.fox.com/entertainment/">Watch FOX Shows</a></li></ul></nav><nav class="menu-about-us"><h6 class="nav-title"><a href="/about" data-name="About Us" class="global-nav-item">About Us</a></h6> <ul><li class="nav-item"><a href="/advertise">Advertise with Us</a></li><li class="nav-item"><a href="/person/all">Personalities</a></li><li class="nav-item"><a href="/tag/entertainment/community">Community Events</a></li><li class="nav-item"><a href="/about">Contact Us</a></li><li class="nav-item"><a href="https://www.wogx.com/jobs">Jobs at FOX 51</a></li><li class="nav-item"><a href="/closed-captioning">Closed Captioning</a></li><li class="nav-item"><a href="https://www.fox35orlando.com/fcc-online-public-file">FCC Public File</a></li><li class="nav-item"><a href="https://www.wogx.com/fcc-applications">FCC Applications</a></li></ul></nav><nav class="menu-news-tips"><h6 class="nav-title"><a href="/about" data-name="News Tips" class="global-nav-item">News Tips</a></h6> <ul><li class="nav-item"><a href="/about">Call: (407) 741-5027</a></li><li class="nav-item"><a href="/about">Email: FOX35Tips@fox.com</a></li></ul></nav></div></div> <div class="footer-lower" data-v-edc3a70c><div class="social-icons-footer" data-v-edc3a70c><ul data-v-edc3a70c><li class="fb" data-v-edc3a70c><a href="https://www.facebook.com/WOGXFox51" data-v-edc3a70c>facebook</a></li><li class="tw" data-v-edc3a70c><a href="https://twitter.com/wogxfox51" data-v-edc3a70c>twitter</a></li><li class="ig" data-v-edc3a70c><a href="https://www.instagram.com/wogxfox51/" data-v-edc3a70c>instagram</a></li><li class="email" data-v-edc3a70c><a href="mailto:WOFLnews@foxtv.com" data-v-edc3a70c>email</a></li></ul></div> <div class="branding" data-v-edc3a70c><a href="/" class="logo" data-v-edc3a70c><img src="//static.foxtv.com/static/orion/img/core/s/logos/fts-ocala-gainesville-b.svg" alt="FOX 51 Gainesville" data-v-edc3a70c></a></div> <div class="legal" data-v-edc3a70c><ul data-v-edc3a70c><li data-v-edc3a70c><a href="/privacy-policy" data-v-edc3a70c>Updated Privacy Policy</a></li><li data-v-edc3a70c><a href="/terms-of-service" data-v-edc3a70c>Terms of Service</a></li><li data-v-edc3a70c><a href="/do-not-sell-my-personal-information" data-v-edc3a70c>Do Not Sell my Personal Information </a></li><li data-v-edc3a70c><a href="https://www.fox35orlando.com/fcc-online-public-file" data-v-edc3a70c>FCC Public File</a></li><li data-v-edc3a70c><a href="https://publicfiles.fcc.gov/tv-profile/wogx/equal-employment-opportunity-records/additional-documents/eeo-public-file-reports/b11fdaf9-7f75-9abf-cb81-6d2f3f29c1b1/" data-v-edc3a70c>EEO Public File</a></li><li data-v-edc3a70c><a href="/closed-captioning" data-v-edc3a70c>Closed Captioning</a></li><li data-v-edc3a70c><a href="/about" data-v-edc3a70c>Contact Us</a></li></ul> <p class="copyright" data-v-edc3a70c>This material may not be published, broadcast, rewritten, or redistributed. ©2022 FOX Television Stations</p></div></div></footer></div></div></div><script>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</script><script src="/_wzln/c05903c53ff394793e81.js" defer></script><script src="/_wzln/d0c01cd7fe6130c168aa.js" defer></script><script src="/_wzln/7dd24738d8a50f86501d.js" defer></script><script src="/_wzln/4781d29d1da383767fba.js" defer></script><script src="/_wzln/f6c9ecd1fd0c1c60a56a.js" defer></script><script src="/_wzln/dd780842d04db44d39b9.js" defer></script><script src="/_wzln/6d0abfe0b75722f245e2.js" defer></script>
    <script type="text/javascript">!function(i){i.Loader&&i.Loader.init()}(window.FTS||{})</script>
  </body>
</html>
