<!doctype html>
<html data-n-head-ssr lang="en" data-n-head="lang">
  <head>
    <title data-n-head="true">Woman visits Disney World every month, donates plasma to cover costs: &#x27;I can help somebody&#x27;</title><meta data-n-head="true" http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"><meta data-n-head="true" name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no"><meta data-n-head="true" charset="UTF-8"><meta data-n-head="true" name="format-detection" content="telephone=no"><meta data-n-head="true" name="msapplication-square70x70logo" content="//static.foxtv.com/static/orion/img/wogx/favicons/mstile-70x70.png"><meta data-n-head="true" name="msapplication-square150x150logo" content="//static.foxtv.com/static/orion/img/wogx/favicons/mstile-150x150.png"><meta data-n-head="true" name="msapplication-wide310x150logo" content="//static.foxtv.com/static/orion/img/wogx/favicons/mstile-310x150.png"><meta data-n-head="true" name="msapplication-square310x310logo" content="//static.foxtv.com/static/orion/img/wogx/favicons/mstile-310x310.png"><meta data-n-head="true" data-hid="description" name="description" content="Liz Gramlich says that her regular visits with her sister to Disney began in 2020."><meta data-n-head="true" data-hid="fb:app_id" property="fb:app_id" content="115512618480878"><meta data-n-head="true" data-hid="prism.stationId" name="prism.stationId" content="WOGX_FOX51"><meta data-n-head="true" data-hid="prism.stationCallSign" name="prism.stationCallSign" content="wogx"><meta data-n-head="true" data-hid="prism.channel" name="prism.channel" content="fts"><meta data-n-head="true" data-hid="prism.section" name="prism.section" content="news"><meta data-n-head="true" data-hid="prism.subsection1" name="prism.subsection1" content=""><meta data-n-head="true" data-hid="prism.subsection2" name="prism.subsection2" content=""><meta data-n-head="true" data-hid="prism.subsection3" name="prism.subsection3" content=""><meta data-n-head="true" data-hid="prism.subsection4" name="prism.subsection4" content=""><meta data-n-head="true" data-hid="prism.aggregationType" name="prism.aggregationType" content="subsection"><meta data-n-head="true" data-hid="prism.genre" name="prism.genre" content=""><meta data-n-head="true" data-hid="pagetype" name="pagetype" content="article" scheme="dcterms.DCMIType"><meta data-n-head="true" data-hid="strikepagetype" name="strikepagetype" content="article" scheme="dcterms.DCMIType"><meta data-n-head="true" data-hid="content-creator" name="content-creator" content="tiger"><meta data-n-head="true" data-hid="dc.creator" name="dc.creator" scheme="dcterms.creator" content=""><meta data-n-head="true" data-hid="dc.title" name="dc.title" content="Woman visits Disney World every month, donates plasma to cover costs: &#x27;I can help somebody&#x27;" lang="en"><meta data-n-head="true" data-hid="dc.subject" name="dc.subject" content=""><meta data-n-head="true" data-hid="dcterms.abstract" name="dcterms.abstract" content="Liz Gramlich says that her regular visits with her sister to Disney began in 2020."><meta data-n-head="true" data-hid="dc.type" name="dc.type" scheme="dcterms.DCMIType" content="Text.Article"><meta data-n-head="true" data-hid="dc.description" name="dc.description" content="Liz Gramlich says that her regular visits with her sister to Disney began in 2020."><meta data-n-head="true" data-hid="dc.language" name="dc.language" scheme="dcterms.RFC4646" content="en-US"><meta data-n-head="true" data-hid="dc.publisher" name="dc.publisher" content="FOX 51 Gainesville"><meta data-n-head="true" data-hid="dc.format" name="dc.format" scheme="dcterms.URI" content="text/html"><meta data-n-head="true" data-hid="dc.identifier" name="dc.identifier" scheme="dcterms.URI" content="urn:uri:base64:bfbe0c3d-1f28-5e68-9bca-8922773c1f75"><meta data-n-head="true" data-hid="dc.source" name="dc.source" content="FOX News"><meta data-n-head="true" data-hid="dc.date" name="dc.date" content="2022-03-29"><meta data-n-head="true" data-hid="dcterms.created" name="dcterms.created" scheme="dcterms.ISO8601" content="2022-03-29T07:44:00-04:00"><meta data-n-head="true" data-hid="dcterms.modified" name="dcterms.modified" scheme="dcterms.ISO8601" content="2022-03-29T11:06:46-04:00"><meta data-n-head="true" data-hid="og:title" property="og:title" content="Woman visits Disney World every month, donates plasma to cover costs: &#x27;I can help somebody&#x27;"><meta data-n-head="true" data-hid="og:description" property="og:description" content="Liz Gramlich says that her regular visits with her sister to Disney began in 2020."><meta data-n-head="true" data-hid="og:type" property="og:type" content="article"><meta data-n-head="true" data-hid="og:image" property="og:image" content="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/1280/720/disney-1.jpg?ve=1&amp;tl=1"><meta data-n-head="true" data-hid="og:image:width" property="og:image:width" content="1280"><meta data-n-head="true" data-hid="og:image:height" property="og:image:height" content="720"><meta data-n-head="true" data-hid="og:url" property="og:url" content="https://www.wogx.com/news/woman-visits-disney-world-every-month-donates-plasma-to-cover-costs-i-can-help-somebody"><meta data-n-head="true" data-hid="og:site_name" property="og:site_name" content="FOX 51 Gainesville"><meta data-n-head="true" data-hid="og:locale" property="og:locale" content="en_US"><meta data-n-head="true" data-hid="robots" name="robots" content="noarchive, noodp, max-image-preview:standard"><meta data-n-head="true" data-hid="fox.app_version" name="fox.app_version" content="v77"><meta data-n-head="true" data-hid="fox.app_build" name="fox.app_build" content="no build version"><meta data-n-head="true" name="apple-itunes-app" content="app-id=undefined, app-argument=https://www.wogx.com/news/woman-visits-disney-world-every-month-donates-plasma-to-cover-costs-i-can-help-somebody"><meta data-n-head="true" name="twitter:card" content="summary_large_image"><meta data-n-head="true" name="twitter:site" content="@wogxfox51"><meta data-n-head="true" name="twitter:site:id" content="@wogxfox51"><meta data-n-head="true" name="twitter:title" content="Woman visits Disney World every month, donates plasma to cover costs: &#x27;I can help somebody&#x27;"><meta data-n-head="true" name="twitter:description" content="Liz Gramlich says that her regular visits with her sister to Disney began in 2020."><meta data-n-head="true" name="twitter:image" content="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/1280/720/disney-1.jpg?ve=1&amp;tl=1"><meta data-n-head="true" name="twitter:url" content="https://www.wogx.com/news/woman-visits-disney-world-every-month-donates-plasma-to-cover-costs-i-can-help-somebody"><meta data-n-head="true" name="twitter:creator" content="@wogxfox51"><meta data-n-head="true" name="twitter:creator:id" content="@wogxfox51"><meta data-n-head="true" name="fox.name" content="Post Landing"><meta data-n-head="true" name="fox.category" content="news"><meta data-n-head="true" name="fox.page_content_category" content="news"><meta data-n-head="true" name="fox.page_name" content="wogx:web:post:article:Woman visits Disney World every month, donates plasma to cover costs: &#x27;I can help somebody&#x27;"><meta data-n-head="true" name="fox.page_content_level_1" content="wogx:web:post"><meta data-n-head="true" name="fox.page_content_level_2" content="wogx:web:post:article"><meta data-n-head="true" name="fox.page_content_level_3" content="wogx:web:post:article:Woman visits Disney World every month, donates plasma to cover costs: &#x27;I can help somebody&#x27;"><meta data-n-head="true" name="fox.page_content_level_4" content="wogx:web:post:article:Woman visits Disney World every month, donates plasma to cover costs: &#x27;I can help somebody&#x27;"><meta data-n-head="true" name="fox.page_type" content="post-article"><meta data-n-head="true" name="fox.page_content_distributor" content="owned"><meta data-n-head="true" name="fox.page_content_type_of_story" content="Partner"><meta data-n-head="true" name="fox.author" content=""><meta data-n-head="true" name="fox.page_content_author" content=""><meta data-n-head="true" name="fox.page_content_author_secondary" content="FOX News"><meta data-n-head="true" name="fox.page_content_version" content="6.0.0"><meta data-n-head="true" name="fox.publisher" content="FOX News"><meta data-n-head="true" name="fox.page_content_id" content="bfbe0c3d-1f28-5e68-9bca-8922773c1f75"><meta data-n-head="true" name="fox.page_content_station_originator" content="wofl"><meta data-n-head="true" name="fox.url" content="https://www.wogx.com/news/woman-visits-disney-world-every-month-donates-plasma-to-cover-costs-i-can-help-somebody"><meta data-n-head="true" name="fox.page_canonical_url" content="https://www.foxnews.com/travel/woman-visits-disney-world-every-month-donates-plasma"><meta data-n-head="true" property="fb:app_id" content="115512618480878"><meta data-n-head="true" property="article:opinion" content="false"><meta data-n-head="true" name="keywords" content="Us,Fl,Alachua County,Gainesville,News"><meta data-n-head="true" name="classification" content="/FTS/Us/Fl/Alachua County/Gainesville,/FTS/News"><meta data-n-head="true" name="classification-isa" content="gainesville,news"><meta data-n-head="true" name="fox.page_content_tags" content="/FTS/Us/Fl/Alachua County/Gainesville,/FTS/News"><link data-n-head="true" rel="icon" type="image/x-icon" href="/favicons/wogx/favicon.ico"><link data-n-head="true" rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open+Sans:400,400i,600,600i,700,700i,800,800i&amp;display=swap"><link data-n-head="true" rel="schema.dcterms" href="//purl.org/dc/terms/"><link data-n-head="true" rel="schema.prism" href="//prismstandard.org/namespaces/basic/2.1/"><link data-n-head="true" rel="schema.iptc" href="//iptc.org/std/nar/2006-10-01/"><link data-n-head="true" rel="shortcut icon" href="//static.foxtv.com/static/orion/img/wogx/favicons/favicon.ico" type="image/x-icon"><link data-n-head="true" rel="apple-touch-icon" sizes="57x57" href="//static.foxtv.com/static/orion/img/wogx/favicons/apple-touch-icon-57x57.png"><link data-n-head="true" rel="apple-touch-icon" sizes="60x60" href="//static.foxtv.com/static/orion/img/wogx/favicons/apple-touch-icon-60x60.png"><link data-n-head="true" rel="apple-touch-icon" sizes="72x72" href="//static.foxtv.com/static/orion/img/wogx/favicons/apple-touch-icon-72x72.png"><link data-n-head="true" rel="apple-touch-icon" sizes="76x76" href="//static.foxtv.com/static/orion/img/wogx/favicons/apple-touch-icon-76x76.png"><link data-n-head="true" rel="apple-touch-icon" sizes="114x114" href="//static.foxtv.com/static/orion/img/wogx/favicons/apple-touch-icon-114x114.png"><link data-n-head="true" rel="apple-touch-icon" sizes="120x120" href="//static.foxtv.com/static/orion/img/wogx/favicons/apple-touch-icon-120x120.png"><link data-n-head="true" rel="apple-touch-icon" sizes="144x144" href="//static.foxtv.com/static/orion/img/wogx/favicons/apple-touch-icon-144x144.png"><link data-n-head="true" rel="apple-touch-icon" sizes="152x152" href="//static.foxtv.com/static/orion/img/wogx/favicons/apple-touch-icon-152x152.png"><link data-n-head="true" rel="apple-touch-icon" sizes="180x180" href="//static.foxtv.com/static/orion/img/wogx/favicons/apple-touch-icon-180x180.png"><link data-n-head="true" rel="icon" type="image/png" href="//static.foxtv.com/static/orion/img/wogx/favicons/favicon-16x16.png" sizes="16x16"><link data-n-head="true" rel="icon" type="image/png" href="//static.foxtv.com/static/orion/img/wogx/favicons/favicon-32x32.png" sizes="32x32"><link data-n-head="true" rel="icon" type="image/png" href="//static.foxtv.com/static/orion/img/wogx/favicons/favicon-96x96.png" sizes="96x96"><link data-n-head="true" rel="icon" type="image/png" href="//static.foxtv.com/static/orion/img/wogx/favicons/android-chrome-192x192.png" sizes="192x192"><link data-n-head="true" rel="canonical" href="https://www.foxnews.com/travel/woman-visits-disney-world-every-month-donates-plasma"><link data-n-head="true" rel="shorturl" href=""><link data-n-head="true" rel="image_src" href="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/1280/720/disney-1.jpg?ve=1&amp;tl=1"><link data-n-head="true" rel="amphtml" href="https://www.wogx.com/news/woman-visits-disney-world-every-month-donates-plasma-to-cover-costs-i-can-help-somebody.amp"><link data-n-head="true" rel="stylesheet" href="//static.foxtv.com/static/orion/css/default/article.rs.css"><link data-n-head="true" rel="stylesheet" href="/css/print.css" media="print"><script data-n-head="true" data-hid="nr-ssr" type="text/javascript" charset="utf-8">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</script><script data-n-head="true" src="https://scripts.webcontentassessor.com/scripts/ef4afbe31ab62a8ae0dd877d983ba92b5fdecfbcaf962df5cd9cbb96afceeca5"></script><script data-n-head="true" src="//static.foxtv.com/static/orion/scripts/core/ag.core.js"></script><script data-n-head="true" src="//static.foxtv.com/static/isa/core.js"></script><script data-n-head="true" src="//static.foxtv.com/static/orion/scripts/station/default/loader.js"></script><script data-n-head="true" src="https://widgets.media.weather.com/wxwidget.loader.js?cid=996314550"></script><script data-n-head="true" src="https://w3.mp.lura.live/player/prod/v3/scripts/anvload.js"></script><script data-n-head="true" src="//static.foxtv.com/static/leap/loader.js"></script><script data-n-head="true" >(function () {
        var _sf_async_config = window._sf_async_config = (window._sf_async_config || {})
        _sf_async_config.uid = 65824
        _sf_async_config.domain = 'wogx.com'
        _sf_async_config.flickerControl = false
        _sf_async_config.useCanonical = true
        _sf_async_config.useCanonicalDomain = true
        })()</script><script data-n-head="true" src="//static.chartbeat.com/js/chartbeat_mab.js"></script><script data-n-head="true" src="https://elections.ap.org/widgets/js/resizer.client.min.js"></script><script data-n-head="true" src="/js/cookies.js"></script><script data-n-head="true" type="application/ld+json">{"@context":"http://schema.org","@type":"NewsArticle","mainEntityOfPage":"https://www.foxnews.com/travel/woman-visits-disney-world-every-month-donates-plasma","headline":"Woman visits Disney World every month, donates plasma to cover costs: 'I can help somebody'","datePublished":"2022-03-29T07:44:00-04:00","dateModified":"2022-03-29T11:06:46-04:00","description":"Liz Gramlich says that her regular visits with her sister to Disney began in 2020.","author":{"@type":"Person","name":"FOX News"},"publisher":{"@type":"Organization","name":"FOX 51 Gainesville","logo":{"@type":"ImageObject","url":"https://static.foxtv.com/static/orion/img/wogx/favicons/favicon-96x96.png","width":"96","height":"96"}},"image":{"@type":"ImageObject","url":"https://static.wogx.com/www.wogx.com/content/uploads/2022/03/disney-1.jpg"},"tags":"news,gainesville","keywords":"news,gainesville"}</script><link rel="preload" href="/_wzln/6ac22b5cb21a5cc776df.js" as="script"><link rel="preload" href="/_wzln/39e75522691442862310.js" as="script"><link rel="preload" href="/_wzln/eb68174f1de737613702.js" as="script"><link rel="preload" href="/_wzln/bb835489dba3bdf0d7fc.js" as="script"><link rel="preload" href="/_wzln/24e434f17fe6c21c7d71.js" as="script"><link rel="preload" href="/_wzln/1aac9905a5625062e600.js" as="script"><link rel="preload" href="/_wzln/a3135d9c7a2f457fc7cf.js" as="script"><style data-vue-ssr-id="4007f7ae:0 12f49b28:0 3958c24a:0 58555669:0 1a21896c:0 78d3cac4:0 55f32066:0 9060c868:0 2aeef825:0 4d2bd7fc:0 65aa3cb4:0 602ddfaa:0 78b03f3e:0 fb9cb2c0:0">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</style>
   
<script>(window.BOOMR_mq=window.BOOMR_mq||[]).push(["addVar",{"rua.upush":"false","rua.cpush":"true","rua.upre":"false","rua.cpre":"true","rua.uprl":"false","rua.cprl":"false","rua.cprf":"false","rua.trans":"SJ-3dc8d9a4-438a-4506-808f-0c86b5f9495d","rua.cook":"false","rua.ims":"false","rua.ufprl":"false","rua.cfprl":"false","rua.isuxp":"false","rua.texp":"norulematch"}]);</script>
                              <script>!function(a){var e="https://s.go-mpulse.net/boomerang/",t="addEventListener";if("False"=="True")a.BOOMR_config=a.BOOMR_config||{},a.BOOMR_config.PageParams=a.BOOMR_config.PageParams||{},a.BOOMR_config.PageParams.pci=!0,e="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="HP9WN-429QT-AGR8G-FBNE8-3RFTX",function(){function n(e){a.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!a.BOOMR||!a.BOOMR.version&&!a.BOOMR.snippetExecuted){a.BOOMR=a.BOOMR||{},a.BOOMR.snippetExecuted=!0;var i,_,o,r=document.createElement("iframe");if(a[t])a[t]("load",n,!1);else if(a.attachEvent)a.attachEvent("onload",n);r.src="javascript:void(0)",r.title="",r.role="presentation",(r.frameElement||r).style.cssText="width:0;height:0;border:0;display:none;",o=document.getElementsByTagName("script")[0],o.parentNode.insertBefore(r,o);try{_=r.contentWindow.document}catch(O){i=document.domain,r.src="javascript:var d=document.open();d.domain='"+i+"';void(0);",_=r.contentWindow.document}_.open()._l=function(){var a=this.createElement("script");if(i)this.domain=i;a.id="boomr-if-as",a.src=e+"HP9WN-429QT-AGR8G-FBNE8-3RFTX",BOOMR_lstart=(new Date).getTime(),this.body.appendChild(a)},_.write("<bo"+'dy onload="document._l();">'),_.close()}}(),"".length>0)if(a&&"performance"in a&&a.performance&&"function"==typeof a.performance.setResourceTimingBufferSize)a.performance.setResourceTimingBufferSize();!function(){if(BOOMR=a.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var e="true"=="true"?1:0,t="",n="eow65cqxblygeysdennq-f-cd92f16be-clientnsv4-s.akamaihd.net",i="false"=="true"?2:1,_={"ak.v":"32","ak.cp":"879161","ak.ai":parseInt("561272",10),"ak.ol":"0","ak.cr":29,"ak.ipv":4,"ak.proto":"http/1.1","ak.rid":"37c25fac","ak.r":28485,"ak.a2":e,"ak.m":"dscr","ak.n":"ff","ak.bpcip":"35.173.238.0","ak.cport":39008,"ak.gh":"23.10.240.94","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"reno","ak.t":"1648567131","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==gxiNvrlEV+rSj083f1eIRJevqiYzP5RE1ndKJVVQ2buWaOSGyBUt3mCz3B/7fctpStF6HpsKeJxzdMWRw/iJi6hG7kbu4NQ0A50SgfFVIlyZwkTVN+98Ma1p+1pbGswjUdyngR3GQeZiI4MHeGyUfsHHr+7wuhUKehC5E5p1j32rDpBj8qrXdvsG6pH9fj1P9obR4Q+Koa7b4VrSlGXPaJpatPjtbOSgq1WMu+fM+k2eNVV8qqkRYK/EEG9tlxrIs9ICD8yZ8JQJbD8ptiIt181BEETmZS1AWev0a/N+ZPJZe9IFLZYjBVKPCgFAKDU0ZE8KvE6mISf8ujhxSZfH3K667lGaUPcAldEIY0/ROmoLqiZbqZMkSD1NIkSSm/6uNvknofcKvf63m/Jiqo4ns/DP0H8Z2CrGbGOTLA9lDRM=","ak.pv":"18","ak.dpoabenc":"","ak.tf":i};if(""!==t)_["ak.ruds"]=t;var o={i:!1,av:function(e){var t="http.initiator";if(e&&(!e[t]||"spa_hard"===e[t]))_["ak.feo"]=void 0!==a.aFeoApplied?1:0,BOOMR.addVar(_)},rv:function(){var a=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t","ak.tf"];BOOMR.removeVar(a)}};BOOMR.plugins.AK={akVars:_,akDNSPreFetchDomain:n,init:function(){if(!o.i){var a=BOOMR.subscribe;a("before_beacon",o.av,null,null),a("onbeacon",o.rv,null,null),o.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head>
  <body class="fb single single-article amp-geo-pending" data-n-head="class">
    <amp-geo layout="nodisplay">
      <script type="application/json">
      {
        "ISOCountryGroups": {
          "eu": ["at", "be", "bg", "cy", "cz", "de", "dk", "ee", "es", "fi", "fr", "gb", "gr", "hr", "hu", "ie", "it", "lt", "lu", "lv", "mt", "nl", "pl", "pt", "ro", "se", "si", "sk"]
        }
      }
      </script>
    </amp-geo>
    <div data-server-rendered="true" id="__nuxt"><div id="__layout"><div id="wrapper" class="wrapper"><header class="site-header nav-closed" data-v-29d3ecd4><!----> <div class="site-header-inner" data-v-89b6539e data-v-29d3ecd4><div class="branding" data-v-89b6539e><a href="/" class="logo" data-v-89b6539e><img src="//static.foxtv.com/static/orion/img/core/s/logos/fts-ocala-gainesville-a.svg" alt="FOX 51 Gainesville" class="logo-full" data-v-89b6539e> <img src="//static.foxtv.com/static/orion/img/core/s/logos/fts-ocala-gainesville-b.svg" alt="FOX 51 Gainesville" class="logo-mini" data-v-89b6539e></a> <!----></div> <div class="nav-row" data-v-89b6539e><div class="primary-nav tablet-desktop" data-v-89b6539e><nav id="main-nav" data-v-89b6539e><ul data-v-89b6539e><li class="menu-live" data-v-89b6539e><a href="/live" data-v-89b6539e><span data-v-89b6539e>Live</span></a></li><li class="menu-news" data-v-89b6539e><a href="/news" data-v-89b6539e><span data-v-89b6539e>News</span></a></li><li class="menu-weather" data-v-89b6539e><a href="/weather" data-v-89b6539e><span data-v-89b6539e>Weather</span></a></li><li class="menu-community" data-v-89b6539e><a href="/tag/entertainment/community" data-v-89b6539e><span data-v-89b6539e>Community</span></a></li><li class="menu-contests" data-v-89b6539e><a href="/contests" data-v-89b6539e><span data-v-89b6539e>Contests</span></a></li> <li class="menu-more" data-v-89b6539e><a href="#" class="js-menu-toggle" data-v-89b6539e>More</a></li></ul></nav></div> <div class="meta" data-v-89b6539e><span data-v-507d0599 data-v-89b6539e><!----> <!----> <!----> <button class="button-reset watch-live mobile" data-v-507d0599><a href="/live" data-v-507d0599>Watch Live</a></button></span> <div class="search-toggle tablet-desktop" data-v-89b6539e><a href="#" class="js-focus-search" data-v-89b6539e>Expand / Collapse search</a></div> <div class="menu mobile" data-v-89b6539e><a href="#" class="js-menu-toggle" data-v-89b6539e>☰</a></div></div></div></div> <div class="expandable-nav" data-v-29d3ecd4><div class="inner" data-v-29d3ecd4><div class="search"><div class="search-wrap"><form autocomplete="off" action="/search" method="get"><fieldset><label for="search-site" class="label">Search site</label> <input id="search-site" type="text" placeholder="Search for keywords" name="q" onblur onfocus autocomplete="off" value="" class="resp_site_search"> <input type="hidden" name="ss" value="fb"> <input type="submit" value="Search" class="resp_site_submit"></fieldset></form></div></div></div> <div class="section-nav" data-v-29d3ecd4><div class="inner"><nav class="menu-regional-news"><h6 class="nav-title"><a href="/local-news">Regional News</a></h6> <ul><li class="nav-item"><a href="https://www.fox35orlando.com/">Orlando News - FOX 35 Orlando</a></li><li class="nav-item"><a href="https://www.fox13news.com/">Tampa News - FOX 13 News</a></li><li class="nav-item"><a href="https://www.fox5atlanta.com/">Atlanta News - FOX 5 Atlanta</a></li></ul></nav><nav class="menu-weather"><h6 class="nav-title"><a href="/weather">Weather</a></h6> <ul><li class="nav-item"><a href="/weather">Interactive Radar</a></li><li class="nav-item"><a href="/weather-alerts">Weather Alerts</a></li><li class="nav-item"><a href="/7-day-forecast">7-Day Forecast</a></li><li class="nav-item"><a href="/hour-by-hour-forecast">Hour-by-Hour Forecast</a></li></ul></nav><nav class="menu-money"><h6 class="nav-title"><a href="https://www.wogx.com/money">Money</a></h6> <ul><li class="nav-item"><a href="/tag/business/personal-finance">Personal Finance</a></li><li class="nav-item"><a href="/tag/money/us-economy">The Economy</a></li><li class="nav-item"><a href="/tag/business/small-business">Small Business</a></li></ul></nav><nav class="menu-tv-listings"><h6 class="nav-title"><a href="/whatsonfox">TV Listings</a></h6> <ul><li class="nav-item"><a href="/whatsonfox">What’s on FOX 51</a></li><li class="nav-item"><a href="https://www.fox.com/entertainment/">Watch FOX Shows</a></li></ul></nav><nav class="menu-about-us"><h6 class="nav-title"><a href="/about">About Us</a></h6> <ul><li class="nav-item"><a href="/advertise">Advertise with Us</a></li><li class="nav-item"><a href="/person/all">Personalities</a></li><li class="nav-item"><a href="/tag/entertainment/community">Community Events</a></li><li class="nav-item"><a href="/about">Contact Us</a></li><li class="nav-item"><a href="https://www.wogx.com/jobs">Jobs at FOX 51</a></li><li class="nav-item"><a href="/closed-captioning">Closed Captioning</a></li><li class="nav-item"><a href="https://www.fox35orlando.com/fcc-online-public-file">FCC Public File</a></li><li class="nav-item"><a href="https://www.wogx.com/fcc-applications">FCC Applications</a></li></ul></nav><nav class="menu-news-tips"><h6 class="nav-title"><a href="/about">News Tips</a></h6> <ul><li class="nav-item"><a href="/about">Call: (407) 741-5027</a></li><li class="nav-item"><a href="/about">Email: FOX35Tips@fox.com</a></li></ul></nav></div></div></div> <iframe id="xd-channel-fts-iframe" src="https://my.foxtv.com/xd-channel.html" role="presentation" data-v-29d3ecd4></iframe></header> <div class="page"><div class="pre-content"><div data-v-6e1c7e98><div class="alert alert-storm tall" data-v-6e1c7e98><div class="alert-inner" data-v-6e1c7e98><a href="/weather-alerts" data-v-6e1c7e98><div class="alert-title" data-v-6e1c7e98>River Flood Warning</div> <div class="alert-text" data-v-6e1c7e98> is in effect, Gilchrist County, Gilchrist County, Alachua County</div></a> <div class="count" data-v-6e1c7e98><span class="hide" data-v-6e1c7e98>3</span> <div class="arrow up" data-v-6e1c7e98></div></div></div></div><div class="alert alert-storm expand tall" data-v-6e1c7e98><div class="alert-inner" data-v-6e1c7e98><a href="/weather-alerts" data-v-6e1c7e98><div class="alert-title" data-v-6e1c7e98>River Flood Warning</div> <div class="alert-text" data-v-6e1c7e98> until SAT 8:00 AM EDT, Alachua County</div></a> <!----></div></div><div class="alert alert-storm expand tall" data-v-6e1c7e98><div class="alert-inner" data-v-6e1c7e98><a href="/weather-alerts" data-v-6e1c7e98><div class="alert-title" data-v-6e1c7e98>River Flood Warning</div> <div class="alert-text" data-v-6e1c7e98> until THU 2:00 AM EDT, Alachua County</div></a> <!----></div></div></div> <div class="pre-content-components"><div><div class="ad-container tablet"><div data-ad-pos="tablet" data-ad-size="728x90" class="ad gpt min-height-ad"></div> <!----></div><div class="ad-container desktop"><div data-ad-pos="desktop" data-ad-size="728x90,970x66,970x250" class="ad gpt min-height-ad"></div> <!----></div><div class="ad-container mobile"><div data-ad-pos="mobile" data-ad-size="" class="ad gpt min-height-ad"></div> <!----></div></div></div></div> <div class="page-content"><main class="main-content"><article id="bfbe0c3d-1f28-5e68-9bca-8922773c1f75" comments="[object Object]" origination_station="WOFL" class="article-wrap"><header lastModifiedDate="2022-03-29T11:06:46-04:00" class="article-header" data-v-d6212dd0><div class="meta" data-v-d6212dd0><!----></div> <h1 class="headline" data-v-d6212dd0>Woman visits Disney World every month, donates plasma to cover costs: 'I can help somebody'</h1> <div class="article-meta article-meta-upper" data-v-d6212dd0><div class="author-byline" data-v-d6212dd0><strong>By </strong>FOX News<!----></div> <div class="article-date" data-v-d6212dd0><strong data-v-d6212dd0>Published</strong> <time data-v-d6212dd0>March 29, 2022 7:54AM</time></div> <div class="article-updated" data-v-d6212dd0><strong data-v-d6212dd0>Updated</strong> 9:28AM</div> <div class="article-updated" data-v-d6212dd0><a href="/tag/news" data-v-d6212dd0>News</a></div> <div class="article-updated" data-v-d6212dd0><a href="https://www.foxnews.com" data-v-d6212dd0>FOX News</a></div></div> <div class="article-meta article-meta-lower" data-v-d6212dd0><div class="article-social" data-v-d6212dd0><div class="social-icons"><ul><li class="fb"><a href="#"><span>Facebook</span></a></li> <li class="tw"><a href="#"><span>Twitter</span></a></li> <!----> <li class="print"><a href="#"><span>Print</span></a></li> <li class="email"><a href="#">Email</a></li></ul></div></div></div></header> <!----> <div class="article-content-wrap sticky-columns"><div class="article-content"><!----> <div class="article-body"><!----> <!----> <div class="big-top featured article-ct" data-v-7d0efd03><div class="m featured-img" data-v-7d0efd03><img src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/764/432/disney-1.jpg?ve=1&amp;tl=1" alt="1b8373fb-disney 1" data-v-7d0efd03> <span class="overlay" data-v-7d0efd03>article</span></div> <div class="info" data-v-7d0efd03><div class="caption" data-v-7d0efd03><p data-v-7d0efd03><span data-v-7d0efd03>Liz Gramlich, 28, from Philadelphia, is going to Disney World once a month in 2022, with her older sister. (Victoria Daniello)</span> <!----></p> <!----></div></div> <!----></div> <!----><!----> <!----> <p><span class="dateline"><strong>ORLANDO, Fla.</strong> - </span>Liz Gramlich is a huge fan of <a href="https://www.fox35orlando.com/tag/theme-parks/walt-disney-world" target="_blank">Disney.&#xA0;</a></p> <!----><!----> <!----> <p>In fact, the 28-year-old from Philadelphia loves Disney so much that for her 2022 New Year&#x2019;s resolution, she set a goal to visit <a href="https://www.fox35orlando.com/tag/theme-parks/walt-disney-world" target="_blank">Walt Disney World</a> in Orlando once a month with her sister.</p> <div data-uid="fts-ar-16" class="vendor-unit"></div> <div data-ad-pos="inread" data-ad-size="1x1" class="ad gpt"></div><!----> <!----> <p>The pair have visited the resort in January, February and March with their latest &quot;magical&quot; adventure booked for April.&#xA0;</p> <!----><div class="ad-container mobile "><div data-ad-pos="mobile" data-ad-size="300x250" class="ad gpt ad-h-250"></div> <!----></div> <!----> <p>Gramlich, who works in inside sales, told Fox News Digital that her regular visits to Disney began in 2020. As COVID-19 hit the U.S., she and her sister started to notice that flight prices were dropping significantly.&#xA0;</p> <!----><!----> <!----> <div><div data-unit-credible=";;" data-in-article="true" class="credible"></div></div> <!----><!----> <!----> <p>Now, with pandemic restrictions being lifted and travel fees rising, Gramlich&#xA0;has gotten creative in order to cover portions of the costs.</p> <!----><!----> <!----> <h2><strong>‘Something we bonded over’</strong></h2> <!----><!----> <!----> <p>Gramlich said she and her sister visited Disney about a dozen times over the last two years.</p> <!----><!----> <!----> <p>In 2020, Gramlich realized that flights to Orlando from Philadelphia were only two hours, so she&apos;d fly out for a one-day-only visit to the theme park.</p> <!----><!----> <!----> <p>For Gramlich, it was the first time she had been to the resort since she was 3 years old.&#xA0;</p> <!----><!----> <!----> <p><a href="https://www.fox35orlando.com/news/disney-h2o-glow-after-hours-event-returns-to-typhoon-lagoon" target="_blank"><strong>RELATED: &apos;Disney H2O Glow After Hours&apos; event returns to Typhoon Lagoon</strong></a></p> <!----><!----> <!----> <p>&quot;This was brand new to us,&quot; Gramlich told Fox News Digital.&#xA0;</p> <!----><!----> <!----> <div class="full-width-image" data-v-0dea8073><img src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/932/524/disney-3.jpg?ve=1&amp;tl=1" alt="disney-3.jpg" data-v-0dea8073> <div class="info" data-v-0dea8073><p data-v-0dea8073><span data-v-0dea8073>Gramlich and her sister started visiting Disney World regularly in 2020, during the coronavirus pandemic. (Victoria Daniello)</span> <!----></p> <div class="caption-expand" data-v-9fae0ea4 data-v-0dea8073><a class="hand-cursor" data-v-9fae0ea4>Expand</a></div></div></div> <!----><!----> <!----> <p>Gramlich said the visits became &quot;a little extra thing to bring some magic and fun to our lives with everything going on in the world right now.&quot;</p> <!----><!----> <!----> <p>&quot;It became something that we bonded over,&quot; she added.</p> <!----><!----> <!----> <p>In January of this year, Gramlich said she had an idea: &quot;I was like, &#x2018;Why don&#x2019;t we do this every month?&#x2019;&quot;</p> <!----><!----> <!----> <h2><strong>Saving on costs – and earning extra income</strong></h2> <!----><!----> <!----> <p>When Gramlich and her sister began visiting <a href="https://www.fox35orlando.com/tag/theme-parks/walt-disney-world" target="_blank">Disney World </a>in the summer of 2020, the lowest price on round trip flights cost $25 from Philadelphia to Orlando.&#xA0;</p> <!----><!----> <!----> <p>&quot;That was cheaper than gas for a round trip somewhere,&quot; Gramlich said.&#xA0;</p> <!----><!----> <!----> <p>Flight costs eventually went up to about $50 for a round trip, but that was still less expensive than the Uber or Lyft from the airport to one of the Disney World parks, Gramlich said.&#xA0;</p> <!----><!----> <!----> <div><blockquote class="tiktok-embed" style="max-width:605px;min-width:325px;" data-video-id="7078040698834128174" cite="https://www.tiktok.com/@diswithliz/video/7078040698834128174"><section><a href="https://www.tiktok.com/@diswithliz" title="@diswithliz" target="_blank">@diswithliz</a> Who’s a Figment fan?🙋‍♀️ <a href="https://www.tiktok.com/tag/figment" target="_blank" title="figment">#figment</a> <a href="https://www.tiktok.com/tag/figmentday" target="_blank" title="figmentday">#figmentday</a> <a href="https://www.tiktok.com/tag/figmenttok" target="_blank" title="figmenttok">#figmenttok</a> <a href="https://www.tiktok.com/tag/figmentthedragon" target="_blank" title="figmentthedragon">#figmentthedragon</a> <a href="https://www.tiktok.com/tag/figmentpopcornbucket" target="_blank" title="figmentpopcornbucket">#figmentpopcornbucket</a> <a href="https://www.tiktok.com/tag/figmentdisney" target="_blank" title="figmentdisney">#figmentdisney</a> <a href="https://www.tiktok.com/tag/distok" target="_blank" title="distok">#distok</a> <a href="https://www.tiktok.com/tag/disneyprincess" target="_blank" title="disneyprincess">#disneyprincess</a> <a href="https://www.tiktok.com/tag/disneytiktok" target="_blank" title="disneytiktok">#disneytiktok</a> <a href="https://www.tiktok.com/tag/disney" target="_blank" title="disney">#disney</a> <a href="https://www.tiktok.com/tag/disneyworld" target="_blank" title="disneyworld">#disneyworld</a> <a href="https://www.tiktok.com/tag/disneyparks" target="_blank" title="disneyparks">#disneyparks</a> <a href="https://www.tiktok.com/tag/disneyworld50" target="_blank" title="disneyworld50">#disneyworld50</a> <a href="https://www.tiktok.com/tag/disneybound" target="_blank" title="disneybound">#disneybound</a> <a href="https://www.tiktok.com/tag/disneychallenge" target="_blank" title="disneychallenge">#disneychallenge</a> <a href="https://www.tiktok.com/tag/disneylove" target="_blank" title="disneylove">#disneylove</a> <a href="https://www.tiktok.com/tag/disneylife" target="_blank" title="disneylife">#disneylife</a> <a href="https://www.tiktok.com/tag/disneylifestyle" target="_blank" title="disneylifestyle">#disneylifestyle</a> <a href="https://www.tiktok.com/tag/disneyadult" target="_blank" title="disneyadult">#disneyadult</a> <a href="https://www.tiktok.com/tag/disneyplus" target="_blank" title="disneyplus">#disneyplus</a> <a href="https://www.tiktok.com/tag/disneychannel" target="_blank" title="disneychannel">#disneychannel</a> <a href="https://www.tiktok.com/tag/disneyresort" target="_blank" title="disneyresort">#disneyresort</a> <a href="https://www.tiktok.com/tag/vacation" target="_blank" title="vacation">#vacation</a> <a href="https://www.tiktok.com/tag/adventure" target="_blank" title="adventure">#adventure</a> <a href="https://www.tiktok.com/tag/florida" target="_blank" title="florida">#florida</a> <a href="https://www.tiktok.com/music/Nobody-Like-U-From-Turning-RedChorus-7063288214429108226" title='♬ Nobody Like U - From "Turning Red"/Chorus - 4*TOWN (From Disney and Pixar’s Turning Red)' target="_blank">♬ Nobody Like U - From "Turning Red"/Chorus - 4*TOWN (From Disney and Pixar’s Turning Red)</a> </section></blockquote><script src="https://www.tiktok.com/embed.js" async="">&nbsp;</script></div> <!----><!----> <!----> <p>However, as fuel prices have increased, so have flight costs, Gramlich said. For her and her sister&#x2019;s April visit, their round trip flights cost $150 each.</p> <!----><!----> <!----> <p>&quot;That&#x2019;s shocking compared to what we&#x2019;ve paid in the past,&quot; Gramlich said. &quot;So we&#x2019;ve had to adjust to make sure we could cover those costs.&quot;</p> <!----><!----> <!----> <p>Gramlich said she plans her monthly visit to Disney based on when the cheapest flights are. In addition, Gramlich donates her plasma &#x2013; the liquid part of blood without blood cells &#x2013; up to twice a week, which helps her cover the costs of flights and hotels.&#xA0;</p> <!----><!----> <!----> <aside class="pull-quote"><p class="quote-text"><strong>"I was like, ‘Oh, I can help somebody by donating plasma instead of doing something else.’"</strong></p> <cite><span class="quote-author">—  </span></cite></aside> <!----><!----> <!----> <p>Depending on when she goes, Gramlich said she makes between $500 and $1,000 per month, which varies based on a variety of factors including if there&apos;s a shortage in her area.&#xA0;</p> <!----><!----> <!----> <p>Gramlich said her clinic doesn&#x2019;t pay for her plasma, rather she&#x2019;s paid for her time.&#xA0;Donating takes Gramlich about 30 minutes, eight times a month.</p> <!----><!----> <!----> <p>At one time, the money Gramlich received for donating plasma covered &quot;the entire cost of being able to go to Disney World,&quot; including flights and other expenses.</p> <!----><!----> <!----> <p><a href="https://www.fox35orlando.com/news/disney-reveals-inside-of-new-guardians-of-the-galaxy-attraction" target="_blank"><strong>RELATED: Disney reveals inside look at new &apos;Guardians of the Galaxy&apos; attraction</strong></a></p> <!----><!----> <!----> <p>With flight costs going up, her plasma donations are still covering a major portion of the trip, but she sometimes has to save a little extra to cover a longer visit or an upgrade to a deluxe resort, she said.</p> <!----><!----> <!----> <p>Plasma donations can benefit adults or children with cancer and people with liver or clotting factor disorders, according to the American Red Cross. It can also help someone who&apos;s suffering from burns, shock, trauma and other medical emergencies, Standford Children&apos;s Health explains on its website. &quot;The proteins and antibodies in plasma are also used in therapies for rare chronic conditions. These include autoimmune disorders and hemophilia,&quot; the website states.</p> <!----><!----> <!----> <div class="full-width-image" data-v-0dea8073><img src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/932/524/997cc1b5-disney-2.jpg?ve=1&amp;tl=1" alt="disney-2.jpg" data-v-0dea8073> <div class="info" data-v-0dea8073><p data-v-0dea8073><span data-v-0dea8073>So far, Gramlich and her sister – who lives in Baltimore – have visited the resort in January, February and March. Their April trip is already booked. (Victoria Daniello)</span> <!----></p> <div class="caption-expand" data-v-9fae0ea4 data-v-0dea8073><a class="hand-cursor" data-v-9fae0ea4>Expand</a></div></div></div> <!----><!----> <!----> <p>Gramlich is glad plasma donations could potentially serve a life-saving purpose.</p> <!----><!----> <!----> <p>&quot;When it came down to it, I was like, &#x2018;Oh, I can help somebody by donating plasma instead of doing something else,&#x2019;&quot; she said.</p> <!----><!----> <!----> <p>She added that her donation center is clear that plasma donation shouldn&#x2019;t be anyone&#x2019;s main source of income, because there&apos;s never a guarantee that you can donate.</p> <!----><!----> <!----> <p>For Gramlich, she said she&#x2019;s sometimes deferred from donating because her pulse is too high, &quot;because I get a little nervous,&quot; she said.</p> <!----><!----> <!----> <p>Gramlich has other cost-saving methods, too.&#xA0;</p> <!----><!----> <!----> <p>The sisters also had annual passes for a time, which gave them discounts, Gramlich said. However, she added that her annual pass has expired and according to a <a href="https://www.foxbusiness.com/lifestyle/disney-world-halts-sale-several-annual-passes" target="_blank"><u>FOX Business report</u></a> from November, non-Florida residents can no longer get annual passes.&#xA0;</p> <!----><!----> <!----> <p>She and her sister&#x2019;s day trips to Disney helped them save on hotels. Now, they&#x2019;ll stay for longer &#x2013; primarily over the weekends &#x2013; but they split their hotel room, which is often at a value resort. They also split ridesharing costs, Gramlich said.</p> <!----><!----> <!----> <h2><strong>‘Always keeps you coming back’</strong></h2> <!----><!----> <!----> <p>Gramlich&#x2019;s recent visits to Disney World have been during the pandemic. She noted how since then, the park is constantly opening, or re-opening new attractions.&#xA0;</p> <!----><!----> <!----> <p>&quot;Every time we go, we experience new things,&quot; Gramlich said. &quot;There&#x2019;s always new experiences that you find, and it becomes your favorite park or your favorite thing to do.&quot;</p> <!----><!----> <!----> <div><blockquote class="tiktok-embed" style="max-width:605px;min-width:325px;" data-video-id="7076782482338860334" cite="https://www.tiktok.com/@diswithliz/video/7076782482338860334"><section><a href="https://www.tiktok.com/@diswithliz" title="@diswithliz" target="_blank">@diswithliz</a> "That’s not how the Force works!" – Han Solo @diswithliz @dizney_prncsliz <a href="https://www.tiktok.com/tag/disney" target="_blank" title="disney">#disney</a> <a href="https://www.tiktok.com/tag/disneyworld" target="_blank" title="disneyworld">#disneyworld</a> <a href="https://www.tiktok.com/tag/disneyparks" target="_blank" title="disneyparks">#disneyparks</a> <a href="https://www.tiktok.com/tag/disneyworld50" target="_blank" title="disneyworld50">#disneyworld50</a> <a href="https://www.tiktok.com/tag/disneybound" target="_blank" title="disneybound">#disneybound</a> <a href="https://www.tiktok.com/tag/disneychallenge" target="_blank" title="disneychallenge">#disneychallenge</a> <a href="https://www.tiktok.com/tag/disneylove" target="_blank" title="disneylove">#disneylove</a> <a href="https://www.tiktok.com/tag/disneylife" target="_blank" title="disneylife">#disneylife</a> <a href="https://www.tiktok.com/tag/disneylifestyle" target="_blank" title="disneylifestyle">#disneylifestyle</a> <a href="https://www.tiktok.com/tag/disneychallenge" target="_blank" title="disneychallenge">#disneychallenge</a> <a href="https://www.tiktok.com/tag/disneyadult" target="_blank" title="disneyadult">#disneyadult</a> <a href="https://www.tiktok.com/tag/disneyplus" target="_blank" title="disneyplus">#disneyplus</a> <a href="https://www.tiktok.com/tag/disneychannel" target="_blank" title="disneychannel">#disneychannel</a> <a href="https://www.tiktok.com/tag/disneyresort" target="_blank" title="disneyresort">#disneyresort</a> <a href="https://www.tiktok.com/tag/vacation" target="_blank" title="vacation">#vacation</a> <a href="https://www.tiktok.com/tag/adventure" target="_blank" title="adventure">#adventure</a> <a href="https://www.tiktok.com/tag/florida" target="_blank" title="florida">#florida</a> <a href="https://www.tiktok.com/tag/starwars" target="_blank" title="starwars">#starwars</a> <a href="https://www.tiktok.com/tag/starwarsfan" target="_blank" title="starwarsfan">#starwarsfan</a> <a href="https://www.tiktok.com/tag/starwarsmemes" target="_blank" title="starwarsmemes">#starwarsmemes</a> <a href="https://www.tiktok.com/tag/starwarstiktok" target="_blank" title="starwarstiktok">#starwarstiktok</a> <a href="https://www.tiktok.com/tag/distok" target="_blank" title="distok">#distok</a> <a href="https://www.tiktok.com/tag/disneytiktok" target="_blank" title="disneytiktok">#disneytiktok</a> <a href="https://www.tiktok.com/tag/disneyresorts" target="_blank" title="disneyresorts">#disneyresorts</a> <a href="https://www.tiktok.com/music/original-sound-6906959474314021634" title="♬ original sound - Notorious" target="_blank">♬ original sound - Notorious</a> </section></blockquote><script src="https://www.tiktok.com/embed.js" async="">&nbsp;</script></div> <!----><!----> <!----> <p>Some of Gramlich&#x2019;s recent favorites at Disney World include the new Star Wars: Rise of the Resistance ride in Hollywood Studios, and the Ohana restaurant in Magic Kingdom for breakfast.&#xA0;</p> <!----><!----> <!----> <aside class="pull-quote"><p class="quote-text"><strong>"This has just been a way… to add a little bit of magic into your life."</strong></p> <cite><!----></cite></aside> <!----><!----> <!----> <p>Gramlich said that her monthly visits to Disney World have offered some much-needed relief after a few difficult years.&#xA0;</p> <!----><!----> <!----> <p>&quot;It&#x2019;s definitely become a great place to be,&quot; Gramlich said. &quot;We&#x2019;ve been sitting in the pandemic all this time&#x2026; And this has just been a way, not to escape, but to add a little bit of magic into your life.&quot;</p> <!----><!----> <!----> <p><strong>DOWNLOAD:&#xA0;</strong><a href="https://www.fox35orlando.com/apps?pid=Web&amp;c=in_article"><strong>FOX 35 NEWS APP</strong></a><strong> | </strong><a href="https://www.fox35orlando.com/apps?pid=Web&amp;c=in_article"><strong>FOX 35 STORM TEAM WEATHER APP</strong></a></p> <!----><!----> <!----> <p>Gramlich said that even though she&#x2019;ll be visiting Disney frequently this year, she doesn&#x2019;t think she&#x2019;ll get tired of it.&#xA0;</p> <!----><!----> <!----> <p>&quot;Maybe we won&#x2019;t go as often [as every month] after this year,&quot; she said. &quot;But I just always feel like Disney opens up something new and gives you a new experience.&quot;</p> <!----><!----> <!----> <p>&quot;In one Disney trip, I never feel like we experience everything that we want to experience,&quot; she added. &quot;So it always keeps you coming back.&quot;</p> <!----><!----> <!----> <p>Get updates at <a href="https://www.foxnews.com/travel/woman-visits-disney-world-every-month-donates-plasma" target="_blank">FOXNews.com</a>&#xA0;</p> <!----><!----> <!----> <p><a href="https://www.fox35orlando.com/weather" target="_blank"><strong>Orlando Weather: Storm alerts, live interactive radar, forecast</strong></a>,<a href="https://www.fox35orlando.com/weather" target="_blank"><strong> and more</strong></a></p> <!----><!----> <!----> <p><strong>Click here for the latest </strong><a href="https://www.fox35orlando.com/news"><strong>Central Florida news</strong></a><strong>, </strong><a href="https://www.fox35orlando.com/news"><strong>Florida stories</strong></a>,<strong> and </strong><a href="https://www.fox35orlando.com/news"><strong>local headlines.</strong></a><strong>&#xA0;</strong></p> <!----><!----> <div class="ad-container mobile "><div data-ad-pos="mobile" data-ad-size="300x251" class="ad gpt ad-h-251"></div> <p class="advert-txt">Advertisement</p></div> <!----> <!---->  <div data-uid="fts-ar-17" class="vendor-unit"></div></div> <!----></div> <aside class="sidebar sidebar-primary"><div class="sticky-region"><div class="sidebar-columns"><div><div class="ad-container tablet"><div data-ad-pos="tablet" data-ad-size="300x600,300x250" class="ad gpt min-height-ad"></div> <!----></div><div class="ad-container desktop"><div data-ad-pos="desktop" data-ad-size="300x600,300x250" class="ad gpt min-height-ad"></div> <!----></div><div class="ad-container mobile"><div data-ad-pos="mobile" data-ad-size="" class="ad gpt min-height-ad"></div> <!----></div></div><section class="collection collection-river" data-v-22ed480e><header class="heading" data-v-22ed480e><h2 class="title" data-v-22ed480e>
      Latest News
    </h2> <!----></header> <div class="content article-list" data-v-22ed480e><article class="article story-1" data-v-22ed480e><!----> <div class="m"><a href="/news/man-accused-of-beating-elderly-victim-outside-publix-in-winter-haven-turns-self-in-police"><div class="responsive-image__container" data-v-0acd4584><div class="responsive-image__lazy-container" style="background-image:url('https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/592/333/c40b04b3-Don-Walker-mug.jpg?ve=1&amp;tl=1');" data-v-0acd4584><img alt="Man accused of beating elderly victim outside Publix in Winter Haven turns self in: police" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/32/18/c40b04b3-Don-Walker-mug.jpg?ve=1&amp;tl=1" data-src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/592/333/c40b04b3-Don-Walker-mug.jpg?ve=1&amp;tl=1" data-srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/1184/666/c40b04b3-Don-Walker-mug.jpg?ve=1&amp;tl=1 2x" style="background:rgba(0,0,0,0);width:592px;margin:auto;height:0;padding-top:56.25%;" data-v-0acd4584></div> <noscript data-v-0acd4584><picture class="responsive-image__picture" data-v-0acd4584><source media="(max-width: 767px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/320/180/c40b04b3-Don-Walker-mug.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/640/360/c40b04b3-Don-Walker-mug.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 1024px) and (max-width: 1279px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/360/203/c40b04b3-Don-Walker-mug.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/720/406/c40b04b3-Don-Walker-mug.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 768px) and (max-width: 1024px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/413/232/c40b04b3-Don-Walker-mug.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/826/464/c40b04b3-Don-Walker-mug.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 1280px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/592/333/c40b04b3-Don-Walker-mug.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/1184/666/c40b04b3-Don-Walker-mug.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584> <img alt="Man accused of beating elderly victim outside Publix in Winter Haven turns self in: police" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/592/333/c40b04b3-Don-Walker-mug.jpg?ve=1&amp;tl=1" data-v-0acd4584></picture></noscript></div> <!----></a></div> <div class="info"><header class="info-header"><div class="meta"><!----></div> <h3 class="title"><a href="/news/man-accused-of-beating-elderly-victim-outside-publix-in-winter-haven-turns-self-in-police">Man accused of beating elderly victim outside Publix in Winter Haven turns self in: police</a></h3></header> <!----> <!----> <!----></div></article><article class="article story-2" data-v-22ed480e><!----> <div class="m"><a href="/news/woman-visits-disney-world-every-month-donates-plasma-to-cover-costs-i-can-help-somebody"><div class="responsive-image__container" data-v-0acd4584><div class="responsive-image__lazy-container" style="background-image:url('https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/592/333/disney-1.jpg?ve=1&amp;tl=1');" data-v-0acd4584><img alt="Woman visits Disney World every month, donates plasma to cover costs: 'I can help somebody'" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/32/18/disney-1.jpg?ve=1&amp;tl=1" data-src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/592/333/disney-1.jpg?ve=1&amp;tl=1" data-srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/1184/666/disney-1.jpg?ve=1&amp;tl=1 2x" style="background:rgba(0,0,0,0);width:592px;margin:auto;height:0;padding-top:56.25%;" data-v-0acd4584></div> <noscript data-v-0acd4584><picture class="responsive-image__picture" data-v-0acd4584><source media="(max-width: 767px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/320/180/disney-1.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/640/360/disney-1.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 1024px) and (max-width: 1279px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/360/203/disney-1.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/720/406/disney-1.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 768px) and (max-width: 1024px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/413/232/disney-1.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/826/464/disney-1.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 1280px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/592/333/disney-1.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/1184/666/disney-1.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584> <img alt="Woman visits Disney World every month, donates plasma to cover costs: 'I can help somebody'" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/592/333/disney-1.jpg?ve=1&amp;tl=1" data-v-0acd4584></picture></noscript></div> <!----></a></div> <div class="info"><header class="info-header"><div class="meta"><!----></div> <h3 class="title"><a href="/news/woman-visits-disney-world-every-month-donates-plasma-to-cover-costs-i-can-help-somebody">Woman visits Disney World every month, donates plasma to cover costs: 'I can help somebody'</a></h3></header> <!----> <!----> <!----></div></article><article class="article story-3" data-v-22ed480e><!----> <div class="m"><a href="/news/incoming-front-could-bring-strong-storms-to-parts-of-florida"><div class="responsive-image__container" data-v-0acd4584><div class="responsive-image__lazy-container" style="background-image:url('https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/592/333/thursday.jpg?ve=1&amp;tl=1');" data-v-0acd4584><img alt="Incoming front could bring strong storms to parts of Florida" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/32/18/thursday.jpg?ve=1&amp;tl=1" data-src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/592/333/thursday.jpg?ve=1&amp;tl=1" data-srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/1184/666/thursday.jpg?ve=1&amp;tl=1 2x" style="background:rgba(0,0,0,0);width:592px;margin:auto;height:0;padding-top:56.25%;" data-v-0acd4584></div> <noscript data-v-0acd4584><picture class="responsive-image__picture" data-v-0acd4584><source media="(max-width: 767px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/320/180/thursday.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/640/360/thursday.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 1024px) and (max-width: 1279px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/360/203/thursday.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/720/406/thursday.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 768px) and (max-width: 1024px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/413/232/thursday.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/826/464/thursday.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 1280px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/592/333/thursday.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/1184/666/thursday.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584> <img alt="Incoming front could bring strong storms to parts of Florida" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/592/333/thursday.jpg?ve=1&amp;tl=1" data-v-0acd4584></picture></noscript></div> <!----></a></div> <div class="info"><header class="info-header"><div class="meta"><!----></div> <h3 class="title"><a href="/news/incoming-front-could-bring-strong-storms-to-parts-of-florida">Incoming front could bring strong storms to parts of Florida</a></h3></header> <!----> <!----> <!----></div></article><article class="article story-4" data-v-22ed480e><!----> <div class="m"><a href="/news/jake-paul-offering-up-to-30m-for-chris-rock-will-smith-boxing-match"><div class="responsive-image__container" data-v-0acd4584><div class="responsive-image__lazy-container" style="background-image:url('https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/592/333/Myung-Chun-Los-Angeles-Times-via-Getty-Images.jpg?ve=1&amp;tl=1');" data-v-0acd4584><img alt="Jake Paul offering up to $30M for Chris Rock-Will Smith boxing match" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/32/18/Myung-Chun-Los-Angeles-Times-via-Getty-Images.jpg?ve=1&amp;tl=1" data-src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/592/333/Myung-Chun-Los-Angeles-Times-via-Getty-Images.jpg?ve=1&amp;tl=1" data-srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/1184/666/Myung-Chun-Los-Angeles-Times-via-Getty-Images.jpg?ve=1&amp;tl=1 2x" style="background:rgba(0,0,0,0);width:592px;margin:auto;height:0;padding-top:56.25%;" data-v-0acd4584></div> <noscript data-v-0acd4584><picture class="responsive-image__picture" data-v-0acd4584><source media="(max-width: 767px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/320/180/Myung-Chun-Los-Angeles-Times-via-Getty-Images.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/640/360/Myung-Chun-Los-Angeles-Times-via-Getty-Images.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 1024px) and (max-width: 1279px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/360/203/Myung-Chun-Los-Angeles-Times-via-Getty-Images.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/720/406/Myung-Chun-Los-Angeles-Times-via-Getty-Images.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 768px) and (max-width: 1024px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/413/232/Myung-Chun-Los-Angeles-Times-via-Getty-Images.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/826/464/Myung-Chun-Los-Angeles-Times-via-Getty-Images.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 1280px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/592/333/Myung-Chun-Los-Angeles-Times-via-Getty-Images.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/1184/666/Myung-Chun-Los-Angeles-Times-via-Getty-Images.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584> <img alt="Jake Paul offering up to $30M for Chris Rock-Will Smith boxing match" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/592/333/Myung-Chun-Los-Angeles-Times-via-Getty-Images.jpg?ve=1&amp;tl=1" data-v-0acd4584></picture></noscript></div> <!----></a></div> <div class="info"><header class="info-header"><div class="meta"><!----></div> <h3 class="title"><a href="/news/jake-paul-offering-up-to-30m-for-chris-rock-will-smith-boxing-match">Jake Paul offering up to $30M for Chris Rock-Will Smith boxing match</a></h3></header> <!----> <!----> <!----></div></article><article class="article story-5" data-v-22ed480e><!----> <div class="m"><a href="/news/orlando-weather-forecast"><div class="responsive-image__container" data-v-0acd4584><div class="responsive-image__lazy-container" style="background-image:url('https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2021/12/592/333/41c2794a-snapshot-19.jpg?ve=1&amp;tl=1');" data-v-0acd4584><img alt="Toasty and sunny ahead of potentially strong storms in Central Florida mid-week" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2021/12/32/18/41c2794a-snapshot-19.jpg?ve=1&amp;tl=1" data-src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2021/12/592/333/41c2794a-snapshot-19.jpg?ve=1&amp;tl=1" data-srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2021/12/1184/666/41c2794a-snapshot-19.jpg?ve=1&amp;tl=1 2x" style="background:rgba(0,0,0,0);width:592px;margin:auto;height:0;padding-top:56.25%;" data-v-0acd4584></div> <noscript data-v-0acd4584><picture class="responsive-image__picture" data-v-0acd4584><source media="(max-width: 767px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2021/12/320/180/41c2794a-snapshot-19.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2021/12/640/360/41c2794a-snapshot-19.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 1024px) and (max-width: 1279px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2021/12/360/203/41c2794a-snapshot-19.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2021/12/720/406/41c2794a-snapshot-19.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 768px) and (max-width: 1024px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2021/12/413/232/41c2794a-snapshot-19.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2021/12/826/464/41c2794a-snapshot-19.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584><source media="(min-width: 1280px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2021/12/592/333/41c2794a-snapshot-19.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2021/12/1184/666/41c2794a-snapshot-19.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584> <img alt="Toasty and sunny ahead of potentially strong storms in Central Florida mid-week" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2021/12/592/333/41c2794a-snapshot-19.jpg?ve=1&amp;tl=1" data-v-0acd4584></picture></noscript></div> <!----></a></div> <div class="info"><header class="info-header"><div class="meta"><!----></div> <h3 class="title"><a href="/news/orlando-weather-forecast">Toasty and sunny ahead of potentially strong storms in Central Florida mid-week</a></h3></header> <!----> <!----> <!----></div></article></div></section><section class="collection collection-trending" data-v-ab53c740><header class="heading" data-v-ab53c740><h3 class="title" data-v-ab53c740>Trending</h3></header> <div class="content article-list" data-v-ab53c740><article class="article story-1" data-v-ab53c740><!----> <div class="m"><a href="/news/florida-teens-accused-of-stealing-pizza-delivery-drivers-vehicle-two-pizza-recovered"><div class="responsive-image__container" data-v-0acd4584><div class="responsive-image__lazy-container" style="background-image:url('https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/100/56/WOFL-Teens-steal-pizza-delivery-driver-March-21.jpg?ve=1&amp;tl=1');" data-v-0acd4584><img alt="Florida teens accused of stealing pizza delivery driver's vehicle; two pizzas recovered" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/32/18/WOFL-Teens-steal-pizza-delivery-driver-March-21.jpg?ve=1&amp;tl=1" data-src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/100/56/WOFL-Teens-steal-pizza-delivery-driver-March-21.jpg?ve=1&amp;tl=1" data-srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/200/112/WOFL-Teens-steal-pizza-delivery-driver-March-21.jpg?ve=1&amp;tl=1 2x" style="background:rgba(0,0,0,0);width:100px;margin:auto;height:0;padding-top:56.00000000000001%;" data-v-0acd4584></div> <noscript data-v-0acd4584><picture class="responsive-image__picture" data-v-0acd4584><source media="(min-width: 320px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/100/56/WOFL-Teens-steal-pizza-delivery-driver-March-21.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/200/112/WOFL-Teens-steal-pizza-delivery-driver-March-21.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584> <img alt="Florida teens accused of stealing pizza delivery driver's vehicle; two pizzas recovered" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/100/56/WOFL-Teens-steal-pizza-delivery-driver-March-21.jpg?ve=1&amp;tl=1" data-v-0acd4584></picture></noscript></div></a></div> <div class="info"><header class="info-header"><div class="meta"><!----></div> <h4 class="title"><a href="/news/florida-teens-accused-of-stealing-pizza-delivery-drivers-vehicle-two-pizza-recovered">Florida teens accused of stealing pizza delivery driver's vehicle; two pizzas recovered</a></h4></header> <!----></div></article><article class="article story-2" data-v-ab53c740><!----> <div class="m"><a href="/weather/a-wet-dress-rehearsal-for-a-rocket-nasa-prepares-artemis-1-for-final-test"><div class="responsive-image__container" data-v-0acd4584><div class="responsive-image__lazy-container" style="background-image:url('https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/100/56/abda313c-artemis.jpg?ve=1&amp;tl=1');" data-v-0acd4584><img alt="A wet dress rehearsal for a rocket? NASA prepares Artemis-1 for final test" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/32/18/abda313c-artemis.jpg?ve=1&amp;tl=1" data-src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/100/56/abda313c-artemis.jpg?ve=1&amp;tl=1" data-srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/200/112/abda313c-artemis.jpg?ve=1&amp;tl=1 2x" style="background:rgba(0,0,0,0);width:100px;margin:auto;height:0;padding-top:56.00000000000001%;" data-v-0acd4584></div> <noscript data-v-0acd4584><picture class="responsive-image__picture" data-v-0acd4584><source media="(min-width: 320px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/100/56/abda313c-artemis.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/200/112/abda313c-artemis.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584> <img alt="A wet dress rehearsal for a rocket? NASA prepares Artemis-1 for final test" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/100/56/abda313c-artemis.jpg?ve=1&amp;tl=1" data-v-0acd4584></picture></noscript></div></a></div> <div class="info"><header class="info-header"><div class="meta"><!----></div> <h4 class="title"><a href="/weather/a-wet-dress-rehearsal-for-a-rocket-nasa-prepares-artemis-1-for-final-test">A wet dress rehearsal for a rocket? NASA prepares Artemis-1 for final test</a></h4></header> <!----></div></article><article class="article story-3" data-v-ab53c740><!----> <div class="m"><a href="/money/todays-mortgage-rates-march-22-2022"><div class="responsive-image__container" data-v-0acd4584><div class="responsive-image__lazy-container" style="background-image:url('https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/100/56/Credible-daily-mortgage-rate-thumbnail-1186618062-58.jpg?ve=1&amp;tl=1');" data-v-0acd4584><img alt="15- and 10-year mortgage rates are buyers' best bet for savings today | March 22, 2022" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/32/18/Credible-daily-mortgage-rate-thumbnail-1186618062-58.jpg?ve=1&amp;tl=1" data-src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/100/56/Credible-daily-mortgage-rate-thumbnail-1186618062-58.jpg?ve=1&amp;tl=1" data-srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/200/112/Credible-daily-mortgage-rate-thumbnail-1186618062-58.jpg?ve=1&amp;tl=1 2x" style="background:rgba(0,0,0,0);width:100px;margin:auto;height:0;padding-top:56.00000000000001%;" data-v-0acd4584></div> <noscript data-v-0acd4584><picture class="responsive-image__picture" data-v-0acd4584><source media="(min-width: 320px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/100/56/Credible-daily-mortgage-rate-thumbnail-1186618062-58.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/200/112/Credible-daily-mortgage-rate-thumbnail-1186618062-58.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584> <img alt="15- and 10-year mortgage rates are buyers' best bet for savings today | March 22, 2022" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/100/56/Credible-daily-mortgage-rate-thumbnail-1186618062-58.jpg?ve=1&amp;tl=1" data-v-0acd4584></picture></noscript></div></a></div> <div class="info"><header class="info-header"><div class="meta"><!----></div> <h4 class="title"><a href="/money/todays-mortgage-rates-march-22-2022">15- and 10-year mortgage rates are buyers' best bet for savings today | March 22, 2022</a></h4></header> <!----></div></article><article class="article story-4" data-v-ab53c740><!----> <div class="m"><a href="/money/todays-mortgage-refinance-rates-march-22-2022"><div class="responsive-image__container" data-v-0acd4584><div class="responsive-image__lazy-container" style="background-image:url('https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/100/56/Credible-daily-mortgage-refi-rates-thumbnail-140396198-62.jpg?ve=1&amp;tl=1');" data-v-0acd4584><img alt="Considering a cash-out refi? Today's refinance rates still appeal | March 22, 2022" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/32/18/Credible-daily-mortgage-refi-rates-thumbnail-140396198-62.jpg?ve=1&amp;tl=1" data-src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/100/56/Credible-daily-mortgage-refi-rates-thumbnail-140396198-62.jpg?ve=1&amp;tl=1" data-srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/200/112/Credible-daily-mortgage-refi-rates-thumbnail-140396198-62.jpg?ve=1&amp;tl=1 2x" style="background:rgba(0,0,0,0);width:100px;margin:auto;height:0;padding-top:56.00000000000001%;" data-v-0acd4584></div> <noscript data-v-0acd4584><picture class="responsive-image__picture" data-v-0acd4584><source media="(min-width: 320px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/100/56/Credible-daily-mortgage-refi-rates-thumbnail-140396198-62.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/200/112/Credible-daily-mortgage-refi-rates-thumbnail-140396198-62.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584> <img alt="Considering a cash-out refi? Today's refinance rates still appeal | March 22, 2022" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/100/56/Credible-daily-mortgage-refi-rates-thumbnail-140396198-62.jpg?ve=1&amp;tl=1" data-v-0acd4584></picture></noscript></div></a></div> <div class="info"><header class="info-header"><div class="meta"><!----></div> <h4 class="title"><a href="/money/todays-mortgage-refinance-rates-march-22-2022">Considering a cash-out refi? Today's refinance rates still appeal | March 22, 2022</a></h4></header> <!----></div></article><article class="article story-5" data-v-ab53c740><!----> <div class="m"><a href="/news/disney-employees-plan-full-day-walkout"><div class="responsive-image__container" data-v-0acd4584><div class="responsive-image__lazy-container" style="background-image:url('https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/100/56/d8142958-snapshot-41.jpg?ve=1&amp;tl=1');" data-v-0acd4584><img alt="Disney employees hold walkout over controversial education legislation" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/32/18/d8142958-snapshot-41.jpg?ve=1&amp;tl=1" data-src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/100/56/d8142958-snapshot-41.jpg?ve=1&amp;tl=1" data-srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/200/112/d8142958-snapshot-41.jpg?ve=1&amp;tl=1 2x" style="background:rgba(0,0,0,0);width:100px;margin:auto;height:0;padding-top:56.00000000000001%;" data-v-0acd4584></div> <noscript data-v-0acd4584><picture class="responsive-image__picture" data-v-0acd4584><source media="(min-width: 320px)" srcset="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/100/56/d8142958-snapshot-41.jpg?ve=1&amp;tl=1, https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/200/112/d8142958-snapshot-41.jpg?ve=1&amp;tl=1 2x" data-v-0acd4584> <img alt="Disney employees hold walkout over controversial education legislation" src="https://images.foxtv.com/static.wogx.com/www.wogx.com/content/uploads/2022/03/100/56/d8142958-snapshot-41.jpg?ve=1&amp;tl=1" data-v-0acd4584></picture></noscript></div></a></div> <div class="info"><header class="info-header"><div class="meta"><!----></div> <h4 class="title"><a href="/news/disney-employees-plan-full-day-walkout">Disney employees hold walkout over controversial education legislation</a></h4></header> <!----></div></article></div></section><div><div class="ad-container tablet"><div data-ad-pos="tablet" data-ad-size="300x251" class="ad gpt min-height-ad"></div> <!----></div><div class="ad-container desktop"><div data-ad-pos="desktop" data-ad-size="300x251" class="ad gpt min-height-ad"></div> <!----></div><div class="ad-container mobile"><div data-ad-pos="mobile" data-ad-size="300x251" class="ad gpt min-height-ad"></div> <!----></div></div></div></div></aside></div></article></main></div></div> <footer class="site-footer" data-v-edc3a70c><!----> <div class="section-nav footer-upper" data-v-edc3a70c><div class="inner"><nav class="menu-regional-news"><h6 class="nav-title"><a href="/local-news">Regional News</a></h6> <ul><li class="nav-item"><a href="https://www.fox35orlando.com/">Orlando News - FOX 35 Orlando</a></li><li class="nav-item"><a href="https://www.fox13news.com/">Tampa News - FOX 13 News</a></li><li class="nav-item"><a href="https://www.fox5atlanta.com/">Atlanta News - FOX 5 Atlanta</a></li></ul></nav><nav class="menu-weather"><h6 class="nav-title"><a href="/weather">Weather</a></h6> <ul><li class="nav-item"><a href="/weather">Interactive Radar</a></li><li class="nav-item"><a href="/weather-alerts">Weather Alerts</a></li><li class="nav-item"><a href="/7-day-forecast">7-Day Forecast</a></li><li class="nav-item"><a href="/hour-by-hour-forecast">Hour-by-Hour Forecast</a></li></ul></nav><nav class="menu-money"><h6 class="nav-title"><a href="https://www.wogx.com/money">Money</a></h6> <ul><li class="nav-item"><a href="/tag/business/personal-finance">Personal Finance</a></li><li class="nav-item"><a href="/tag/money/us-economy">The Economy</a></li><li class="nav-item"><a href="/tag/business/small-business">Small Business</a></li></ul></nav><nav class="menu-tv-listings"><h6 class="nav-title"><a href="/whatsonfox">TV Listings</a></h6> <ul><li class="nav-item"><a href="/whatsonfox">What’s on FOX 51</a></li><li class="nav-item"><a href="https://www.fox.com/entertainment/">Watch FOX Shows</a></li></ul></nav><nav class="menu-about-us"><h6 class="nav-title"><a href="/about">About Us</a></h6> <ul><li class="nav-item"><a href="/advertise">Advertise with Us</a></li><li class="nav-item"><a href="/person/all">Personalities</a></li><li class="nav-item"><a href="/tag/entertainment/community">Community Events</a></li><li class="nav-item"><a href="/about">Contact Us</a></li><li class="nav-item"><a href="https://www.wogx.com/jobs">Jobs at FOX 51</a></li><li class="nav-item"><a href="/closed-captioning">Closed Captioning</a></li><li class="nav-item"><a href="https://www.fox35orlando.com/fcc-online-public-file">FCC Public File</a></li><li class="nav-item"><a href="https://www.wogx.com/fcc-applications">FCC Applications</a></li></ul></nav><nav class="menu-news-tips"><h6 class="nav-title"><a href="/about">News Tips</a></h6> <ul><li class="nav-item"><a href="/about">Call: (407) 741-5027</a></li><li class="nav-item"><a href="/about">Email: FOX35Tips@fox.com</a></li></ul></nav></div></div> <div class="footer-lower" data-v-edc3a70c><div class="social-icons-footer" data-v-edc3a70c><ul data-v-edc3a70c><li class="fb" data-v-edc3a70c><a href="https://www.facebook.com/WOGXFox51" data-v-edc3a70c>facebook</a></li><li class="tw" data-v-edc3a70c><a href="https://twitter.com/wogxfox51" data-v-edc3a70c>twitter</a></li><li class="ig" data-v-edc3a70c><a href="https://www.instagram.com/wogxfox51/" data-v-edc3a70c>instagram</a></li><li class="email" data-v-edc3a70c><a href="mailto:WOFLnews@foxtv.com" data-v-edc3a70c>email</a></li></ul></div> <div class="branding" data-v-edc3a70c><a href="/" class="logo" data-v-edc3a70c><img src="//static.foxtv.com/static/orion/img/core/s/logos/fts-ocala-gainesville-b.svg" alt="FOX 51 Gainesville" data-v-edc3a70c></a></div> <div class="legal" data-v-edc3a70c><ul data-v-edc3a70c><li data-v-edc3a70c><a href="/privacy-policy" data-v-edc3a70c>Updated Privacy Policy</a></li><li data-v-edc3a70c><a href="/terms-of-service" data-v-edc3a70c>Terms of Service</a></li><li data-v-edc3a70c><a href="/do-not-sell-my-personal-information" data-v-edc3a70c>Do Not Sell my Personal Information </a></li><li data-v-edc3a70c><a href="https://www.fox35orlando.com/fcc-online-public-file" data-v-edc3a70c>FCC Public File</a></li><li data-v-edc3a70c><a href="https://publicfiles.fcc.gov/tv-profile/wogx/equal-employment-opportunity-records/additional-documents/eeo-public-file-reports/b11fdaf9-7f75-9abf-cb81-6d2f3f29c1b1/" data-v-edc3a70c>EEO Public File</a></li><li data-v-edc3a70c><a href="/closed-captioning" data-v-edc3a70c>Closed Captioning</a></li><li data-v-edc3a70c><a href="/about" data-v-edc3a70c>Contact Us</a></li></ul> <p class="copyright" data-v-edc3a70c>This material may not be published, broadcast, rewritten, or redistributed. ©2022 FOX Television Stations</p></div></div></footer></div></div></div><script>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</script><script src="/_wzln/6ac22b5cb21a5cc776df.js" defer></script><script src="/_wzln/24e434f17fe6c21c7d71.js" defer></script><script src="/_wzln/1aac9905a5625062e600.js" defer></script><script src="/_wzln/a3135d9c7a2f457fc7cf.js" defer></script><script src="/_wzln/39e75522691442862310.js" defer></script><script src="/_wzln/eb68174f1de737613702.js" defer></script><script src="/_wzln/bb835489dba3bdf0d7fc.js" defer></script>
    <script type="text/javascript">!function(i){i.Loader&&i.Loader.init()}(window.FTS||{})</script>
  </body>
</html>
